[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Public WebGL] postfix for names in WEBGL_* extensions



I just want to make sure so I don't waste my time change code that
later to be changed again.

So we are going to keep the _WEBGL postfix in the current
WEBGL_draw_buffers extension, correct?

like COLOR_ATTACHMENTi_WEBGL, DRAW_BUFFERi_WEBGL, and drawBuffersWEBGL()?

If yes, we need to modify the conformance test to reflect the change.

On Fri, Mar 15, 2013 at 11:38 AM, Gregg Tavares <gman@google.com> wrote:
> Extensions with suffixes
>
>   OES_texture_half_float
>   OES_standard_derivatives
>   OES_vertex_array_object
>   WEBGL_debug_renderer_info
>   WEBGL_compressed_texture_s3tc
>   WEBGL_depth_texture
>   EXT_texture_filter_anisotropic
>
> Extensions without suffixes
>
>   WEBGL_debug_shaders
>   WEBGL_lose_context
>
> Extensions that don't add any identifiers
>
>   OES_texture_float
>   OES_element_index_uint
>
> I guess suffixes win. Keep the suffixes.
>
>
> On Fri, Mar 15, 2013 at 11:10 AM, Brandon Jones <bajones@google.com> wrote:
>>
>> I feel like we've had this conversation before.
>>
>> For the record I share Gregg's opinion that the suffixes are redundant
>> within the context of WebGL, and I would have preferred them to be removed.
>> I can't, however, see any reasonable way to do that now without either
>> breaking a lot of existing apps (which is not an option) or having some cut
>> off point where the naming convention suddenly changes (which is awkward at
>> best.) Given that, the current convention isn't so offensive that I would
>> push for it to be changed.
>>
>>
>> On Fri, Mar 15, 2013 at 10:57 AM, Gregg Tavares <gman@google.com> wrote:
>>>
>>>
>>>
>>>
>>> On Fri, Mar 15, 2013 at 10:40 AM, Kenneth Russell <kbr@google.com> wrote:
>>>>
>>>>
>>>> The OpenGL convention is that extension FOO_extension_name contains
>>>> enumerants GL_BAR_FOO and function names glBarFOO. That was the
>>>> rationale for changing the suffixes in WEBGL_draw_buffers even though
>>>> the enumerants and functions are all specified by EXT_draw_buffers.
>>>> Personally, I prefer this convention for consistency.
>>>
>>>
>>> WebGL is not OpenGL. Our extensions are on separate objects so there's no
>>> conflicts like there would be in OpenGL where everything is global.
>>>
>>> I think it should be
>>>
>>>    drawBuffersExt = gl.getExtensions("WEBGL_draw_buffers");
>>>    var bufs = [
>>>        drawBuffersExt.COLOR_ATTACHMENT0,
>>>        drawBuffersExt.COLOR_ATTACHMENT1,
>>>        drawBuffersExt.COLOR_ATTACHMENT2,
>>>    ];
>>>    drawBuffersExt.drawBuffers(bufs);
>>>
>>> No need to make it messier by adding unneeded suffixes.
>>>
>>>
>>>>
>>>>
>>>> Changing the names in community approved extensions like
>>>> WEBGL_compressed_texture_s3tc is not feasible because there is code
>>>> already out there referencing them. However, changes could be made in
>>>> draft extensions if there is strong feeling about adopting a
>>>> particular convention.
>>>>
>>>> -Ken
>>>>
>>>>
>>>> On Fri, Mar 15, 2013 at 10:20 AM, Zhenyao Mo <zmo@chromium.org> wrote:
>>>> >
>>>> > I understand we change the extension name to WEBGL_, but do we need to
>>>> > change the related enum names and function names?
>>>> >
>>>> > On Fri, Mar 15, 2013 at 10:17 AM, Brandon Jones <bajones@google.com>
>>>> > wrote:
>>>> >> My understanding has been that we adopt the WEBGL Pre/Postfixes if
>>>> >> the
>>>> >> behavior of the WebGL extension differs from the behavior of the
>>>> >> underlying
>>>> >> extension. This is usually due to additional restrictions being
>>>> >> placed on
>>>> >> the WebGL variant for security or compatibility reasons.
>>>> >>
>>>> >>
>>>> >> On Fri, Mar 15, 2013 at 9:42 AM, Patrick Baggett
>>>> >> <baggett.patrick@gmail.com>
>>>> >> wrote:
>>>> >>>
>>>> >>> FOO_some_neat_feature generally results in SOME_FEATURE_ENUM_FOO
>>>> >>>
>>>> >>>
>>>> >>> Unless there is a specific reason that the suffix should not match
>>>> >>> (breaking OpenGL convention), I vote they all change into _WEBGL.
>>>> >>>
>>>> >>> Patrick
>>>> >>>
>>>> >>>
>>>> >>>
>>>> >>> On Fri, Mar 15, 2013 at 11:11 AM, Zhenyao Mo <zmo@chromium.org>
>>>> >>> wrote:
>>>> >>>>
>>>> >>>>
>>>> >>>> Look at WEBGL_* extension:
>>>> >>>>
>>>> >>>> WEBGL_compressed_texture_s3tc
>>>> >>>> WEBGL_depth_texture
>>>> >>>> WEBGL_lose_context
>>>> >>>> WEBGL_color_buffer_float
>>>> >>>> WEBGL_compressed_texture_atc
>>>> >>>> WEBGL_compressed_texture_pvrtc
>>>> >>>> WEBGL_draw_buffers
>>>> >>>>
>>>> >>>> Some keep the _EXT postfix in their names, for example:
>>>> >>>>
>>>> >>>> in WEBGL_compressed_texture_s3tc
>>>> >>>>
>>>> >>>>    COMPRESSED_RGB_S3TC_DXT1_EXT
>>>> >>>>    COMPRESSED_RGBA_S3TC_DXT1_EXT
>>>> >>>>    COMPRESSED_RGBA_S3TC_DXT3_EXT
>>>> >>>>    COMPRESSED_RGBA_S3TC_DXT5_EXT
>>>> >>>>
>>>> >>>> Some change the postfix to _WEBGL, for example:
>>>> >>>>
>>>> >>>> in WEBGL_depth_texture
>>>> >>>>    UNSIGNED_INT_24_8_WEBGL
>>>> >>>> in WEBGL_draw_buffers
>>>> >>>>    COLOR_ATTACHMENT*_WEBGL
>>>> >>>>    DRAW_BUFFER*_WEBGL
>>>> >>>>    drawBuffersWEBGL()
>>>> >>>>
>>>> >>>> I think we need to decide which way to go.  Otherwise it's very
>>>> >>>> confusing for developers.
>>>> >>>>
>>>> >>>> I prefer to keep the _EXT postfix, but as far as it's consistent
>>>> >>>> across extensions, I am ok.
>>>> >>>>
>>>> >>>> Please vote.
>>>> >>>>
>>>> >>>> -----------------------------------------------------------
>>>> >>>> You are currently subscribed to public_webgl@khronos.org.
>>>> >>>> To unsubscribe, send an email to majordomo@khronos.org with
>>>> >>>> the following command in the body of your email:
>>>> >>>> unsubscribe public_webgl
>>>> >>>> -----------------------------------------------------------
>>>> >>>>
>>>> >>>
>>>> >>
>>>> >
>>>> > -----------------------------------------------------------
>>>> > You are currently subscribed to public_webgl@khronos.org.
>>>> > To unsubscribe, send an email to majordomo@khronos.org with
>>>> > the following command in the body of your email:
>>>> > unsubscribe public_webgl
>>>> > -----------------------------------------------------------
>>>> >
>>>>
>>>> -----------------------------------------------------------
>>>> You are currently subscribed to public_webgl@khronos.org.
>>>> To unsubscribe, send an email to majordomo@khronos.org with
>>>> the following command in the body of your email:
>>>> unsubscribe public_webgl
>>>> -----------------------------------------------------------
>>>>
>>>
>>
>

-----------------------------------------------------------
You are currently subscribed to public_webgl@khronos.org.
To unsubscribe, send an email to majordomo@khronos.org with
the following command in the body of your email:
unsubscribe public_webgl
-----------------------------------------------------------