[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Public WebGL] postfix for names in WEBGL_* extensions



Look at WEBGL_* extension:

WEBGL_compressed_texture_s3tc
WEBGL_depth_texture
WEBGL_lose_context
WEBGL_color_buffer_float
WEBGL_compressed_texture_atc
WEBGL_compressed_texture_pvrtc
WEBGL_draw_buffers

Some keep the _EXT postfix in their names, for example:

in WEBGL_compressed_texture_s3tc

   COMPRESSED_RGB_S3TC_DXT1_EXT
   COMPRESSED_RGBA_S3TC_DXT1_EXT
   COMPRESSED_RGBA_S3TC_DXT3_EXT
   COMPRESSED_RGBA_S3TC_DXT5_EXT

Some change the postfix to _WEBGL, for example:

in WEBGL_depth_texture
   UNSIGNED_INT_24_8_WEBGL
in WEBGL_draw_buffers
   COLOR_ATTACHMENT*_WEBGL
   DRAW_BUFFER*_WEBGL
   drawBuffersWEBGL()

I think we need to decide which way to go.  Otherwise it's very
confusing for developers.

I prefer to keep the _EXT postfix, but as far as it's consistent
across extensions, I am ok.

Please vote.

-----------------------------------------------------------
You are currently subscribed to public_webgl@khronos.org.
To unsubscribe, send an email to majordomo@khronos.org with
the following command in the body of your email:
unsubscribe public_webgl
-----------------------------------------------------------