[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Public WebGL] Differences between Chrome & Minefield



I am using Minefield 4.0b5pre Mozilla/5.0 (Windows NT 5.1; rv:2.0b5pre Gecko/20100819 Minefield/4.0b5pre. I do not see any error from create program, although the shader validator is supposedly enabled, and the sample runs. I just double checked and I do have the shader validator enabled which is shown as the default value. It looks like some bug has crept into Minefield/Firefox since beta 2.

When I wrote my first message, I was a bit confused by this.createProgram. It's his own, not gl.createProgram. Because of this, I was thinking compilation would come later so shader content would not related to the error.

Regards

-Mark



On 2010/08/19 15:24, Gregg Tavares (wrk) wrote:
I see effectively the same error in Firefox 4 beta 2 as in Chromium.

In Firefox I get this error:
Error: this.createProgram(c3dl.psys_vs, c3dl.psys_fs) is null
Source File: http://www.c3dl.org/wp-content/2.0Release/canvas3dapi/renderer/rendererwebgl.js
Line: 502


In Chromium I get
  1. Uncaught TypeError: Cannot call method 'getProgramID' of null
    1. J3DXplorer_mainJ3DXplorer.js:32
    2. c3dl.ColladaQueue.popFrontcolladaqueue.js:84
    3. xmlhttp.onreadystatechange







Same line in both browsers.

On Thu, Aug 19, 2010 at 3:19 PM, Gregg Tavares (wrk) <gman@google.com> wrote:
I don't know why that site is getting that specific error but I tried the second tutorial and the code is using non WebGL stuff. (ie, Desktop OpenGL stuff)

His shaders are referencing gl_FrontColor and gl_TexCoord, neither of which are part of WebGL.



On Thu, Aug 19, 2010 at 1:17 PM, Mark Callow <callow_mark@hicorp.co.jp> wrote:

Hi,

The WebGL sample at www.c3dl.org does not run on Chrome but does run on Minefield.

On Minefield I see in the error console "enable: invalid enum 0x8642" and the sample runs.

On Chrome I see "Uncaught TypeError: Cannot call method 'getProgramID' of null.

The latter is caused by a createProgram call returning null. I am curious why a createProgram call could fails on Chrome and succeed on Minefield. They are the very latest builds downloaded this morning and are running on the same machine. The problem is 100% repeatable.

Regards

-Mark







begin:vcard
fn:Mark Callow
n:Callow;Mark
org:HI Corporation;Middleware Development
adr:Higashiyama 1-4-4, Meguro-ku;;Meguro Higashiyama Bldg 5F;Tokyo;;153-0043;Japan
email;internet:callow_mark@hicorp.co.jp
title:Chief Architect
tel;work:+81 3 3710 9367
tel;fax:+81 3 5773 8660
x-mozilla-html:TRUE
url:http://www.hicorp.co.jp, http://www.mascotcapsule.com
version:2.1
end:vcard