[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Public WebGL] Chromium/Firefox handling of FloatArray



On Tue, Jun 1, 2010 at 12:53 PM, Vladimir Vukicevic
<vladimir@mozilla.com> wrote:
>
> ----- "Kenneth Russell" <kbr@google.com> wrote:
>
>> On Fri, May 28, 2010 at 1:47 PM, Vladimir Vukicevic
>> <vladimir@mozilla.com> wrote:
>> >
>> > ----- "Alan Chaney" <alan@mechnicality.com> wrote:
>> >
>> > This code works fine on Chromium 6.0.408.1.dev (which claims to be
>> up to
>> > date) but fails on Firefox 3.7a5pre.
>> > The Error console says: "$wnd.FloatArray is not a constructor."
>> >
>> > Since the code is based on the current WebGL spec + the TypedArray
>> spec
>> > I assume that Chromium is getting it right? Or
>> > what am I doing wrong?
>> >
>> > Hmm, whoops -- these are called Float32Array and Float64Array in
>> Firefox,
>> > but it looks like I missed updating those names in the original
>> Typed Array
>> > draft spec.  I believe that you can temporarily use WebGLFloatArray
>> and have
>> > things work in both.
>> >
>> > I need to check with Ken and others if there's any strong preference
>> for
>> > naming here -- the Float -> Float32, Double -> Float64 change
>> happened based
>> > on feedback that it's more consistent with Int8/Uint8 etc., and that
>> it
>> > makes it more natural to extend to Float128 and possibly Float16 in
>> the
>> > future.
>>
>> Is there precedent for this naming convention in the current or
>> forthcoming ECMAScript specifications? The Int8, Uint8, etc. naming
>> convention is good because (some of) these types are already in
>> ECMA-262. I see parseFloat() in ECMA-262 which makes me prefer the
>> current Float and Double type names, though I don't feel strongly
>> about it.
>
> Hmm, not sure -- note that parseFloat will end up parsing a double because that's the only floating point type that JS has... so I don't think we should necessarily follow that :-)

Understood. It's OK with me if we make this change now; any comments
from the WebKit team?

-Ken

-----------------------------------------------------------
You are currently subscribed to public_webgl@khronos.org.
To unsubscribe, send an email to majordomo@khronos.org with
the following command in the body of your email: