[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Public WebGL] Issues with WebGL Conformance 1.0.1b



 

The current webgl-conformance-tests.html fails a few tests that I’m hoping can be remedied with test changes.

 

1)      Context/context-attributes-alpha-depth-stencil-antialias.html: The test makes assumptions about the location of attributes ‘pos’ and ‘colorIn’.  The test is missing either a bindAttribLocation before the program link or a getAttribLocation after.

2)      Glsl/functions/glsl-function-mod-gentype.html: The test is enhanced over the GLES2 version of conformance by using two different modulo divisors that are more unique than the ‘1.0’ used in GLES2 conformance.  That’s a good thing.  However the hardware I’m testing on has a 1 bit lsb difference between the built-in and the emulated shader image results.  The 1 bit lsdb delta happens at  the top and bottom extremes for the ‘y’ component.  I would like to request a ‘tolerance:1,’ parameter be used for glsl-function-mod-gentype.html so that it will pass.

3)      Glsl/functions/glsl-function-normalize.html: The test is enhanced over the GLES2 version of conformance by extending the range of the vector components.  This seems like a good thing too.  But I am seeing a 1 bit lsb difference for a few pixels when comparing the results for the built-in versus emulated shaders.  I would like to request a ‘tolerance:1,’ parameter for the glsl-function-normalize.html test too.

 

Robert Tray