[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Public WebGL] Aquarium demo broken with ANGLE/Intel GMA graphics (was Re: [Public WebGL] Getting FF4 to use ANGLE)



It's wasn't with Minefield. It was with Chrome Canary build as in the original report and therefore already using Angle. Sorry for the confusion. I should have changed the message subject.

The GL driver for these Intel integrated graphics chips is only 1.4 so there was never a chance of anything running without ANGLE.

When I get time, probably tomorrow, I'll try the latest Minefield on my notebook computer.

Regards

-Mark



On 10/12/2010 21:51, Benoit Jacob wrote:
A colleague of mine just encountered the same problem with the
aquarium demo on a completely different computer, a Dell desktop
rather than a Panasonic notebook, but also having an Intel integrated
graphics chip. This time a GMA 3100. I don't know if the problem is
with ANGLE or Intel's D3D9 driver for XP but it looks like something
that needs to be fixed if WebGL is not to get a bad reputation.
What Minefield version did he try? A few days ago, Vlad pushed changes making us use ANGLE D3D rendering on Windows and updating our copy of ANGLE. So hopefully this should be resolved in the latest nightly builds?

Benoit
begin:vcard
fn:Mark Callow
n:Callow;Mark
org:HI Corporation;Graphics Lab, Research & Development
adr:Higashiyama 1-4-4, Meguro-ku;;Meguro Higashiyama Bldg 5F;Tokyo;;153-0043;Japan
email;internet:callow_mark@hicorp.co.jp
title:Chief Architect
tel;work:+81 3 3710 9367 x228
tel;fax:+81 3 5773 8660
x-mozilla-html:TRUE
url:http://www.hicorp.co.jp,  http://www.mascotcapsule.com
version:2.1
end:vcard