[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Public WebGL] updating apps & demos for current spec



Hi all,

First off, thanks for the enormous interest in WebGL over the past year!  It's been pretty amazing to see what people have put together, even given a draft spec and alpha/beta implementations.  However, as we get (very) close to 1.0, we could use your help in making sure that your applications and demos are updated for the current state of WebGL.  We've had to make various changes in both the API and functionality that have made most of the demos created earlier in the year stop working.

If you have time, please try to update your apps so that they will run on a recent Firefox or Chrome nightly build.  If you're unable to do so, it would be helpful if you could add a note to the page saying that it was written for an earlier version of WebGL, and is not expected to run on 1.0.

Also, if your app is listed on http://khronos.org/webgl/wiki/User_Contributions please try to update it!  We'll be going through that page soon and removing entries that don't work with the current spec.  If your app is /not/ listed on that page, and works with the current spec, please do add it!  We'd like to have a page to point users to so they can experiment with various uses of WebGL, and want to ensure that they don't end up with broken content or errors.

If you run into problems while attempting to update, send an email to the list and we'll see if we can get it resolved.  Unfortunately, there are some things that won't be possible to update (especially GLSL issues, like non-constant loops).  Keep those around for a potential future version of the spec or extension that relaxes those constraints.

Thanks again,

    - Vlad
-----------------------------------------------------------
You are currently subscribed to public_webgl@khronos.org.
To unsubscribe, send an email to majordomo@khronos.org with
the following command in the body of your email: