[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Public WebGL] tex-image-and-sub-image-2d-with-video



This piqued my interest. Unfortunately it doesn't run on FF4b7 - get an empty video window. Problem is

Warning: WebGL: getUniformLocation: program: null object passed as argument
Source File: https://cvs.khronos.org/svn/repos/registry/trunk/public/webgl/sdk/tests/conformance/tex-image-and-sub-image-2d-with-video.html
Line: 33
In Chrome it is not very visually interesting; no video is shown only, momentarily, the video control bar. It also fails most of the tests.

Maybe I need to do something other than click in the .html file in the test repository. (I had already seen Adrienne's message before I tried this, so I should be using the fixed version.)

Does anyone have a working example of video to a texture in a Canvas 3D?

Regards

-Mark


Hi, I noted a small mistake in tex-image-and-sub-image-2d-with-video.
The video element is set to autoplay which means that the video has already started when the event listener is added in body onload. The TC currently times out, removing the autoplay it works fine as it's calling video.play() immediately after adding the event listener.

begin:vcard
fn:Mark Callow
n:Callow;Mark
org:HI Corporation;Graphics Lab, Research & Development
adr:Higashiyama 1-4-4, Meguro-ku;;Meguro Higashiyama Bldg 5F;Tokyo;;153-0043;Japan
email;internet:callow_mark@hicorp.co.jp
title:Chief Architect
tel;work:+81 3 3710 9367 x228
tel;fax:+81 3 5773 8660
x-mozilla-html:TRUE
url:http://www.hicorp.co.jp,  http://www.mascotcapsule.com
version:2.1
end:vcard