[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Public WebGL] Getting FF4 to use ANGLE



Funny you should ask that. I have just tried it. It appears the GMA 950's D3D9 driver isn't that great either.

Gregg's aquarium  demo (http://websamples.googlecode.com/hg/aquarium/aquarium.html) runs but looks terrible. Many triangles aren't textured and which are & aren't changes with each frame causing horrible flashing. I'm running Chrome Canary build 9.0.576.0.

When I run it on my NVIDIA-equipped desktop computer, using the continuous build Chrome 9.0.583.0 (66100), without "--use-gl=desktop", the aquarium looks fine so the problem appearsrelated to the Intel graphics driver, but oops, it just froze. Oops. The canary build on my notebook computer just froze too.

Attached is a screen shot showing the incorrect rendering.

As for the freeze, in both cases, when I restarted Chrome, the demo would run for  only a few frames then freeze again. I tried many times. Eventually I rebooted the notebook and the demo is running again. On the desktop side, I reinstituted "-use-gl=desktop" and the demo runs again.

Hmm. The demo has now been running on the rebooted notebook for about 10 minutes, looks ugly, but keeps on moving. Meanwhile the desktop machine blue-screened after (1) Chrome 9.0.583.0 (66100) seemed to hang when trying to reload the aquarium demo, (2) I clicked the 'X' button and (3) clicked 'end now' to the dialog telling me the program was unresponsive. What fun.  :-(

Regards

-Mark





On 15/11/2010 16:46, Vangelis Kokkevis wrote:
Hi Mark, 
 I can't speak for the other browsers but have you tried running Chrome? It uses ANGLE by default on windows.

Vangelis


On Sun, Nov 14, 2010 at 11:31 PM, Mark Callow <callow_mark@hicorp.co.jp> wrote:

Hi,

I'm trying to see if I can get WebGL content to run accelerated on my notebook computer (Panasonic Let's Note with a 1.06GHz Core2 CPU, an on-board Intel GMA 950 graphics chip and DirectX 9). The GL driver for this chip is reputedly not good so I want to try ANGLE. I got the latest Minefield build (4.0b8pre). webgl.mochitest_native_gl is at the default "false" setting. I thought this would mean it would use ANGLE but I haven't had any luck running any of the demos from the wiki. Most indicate inability to obtain a webgl context but at least 1 just gives an empty page.

How do I force FF to use ANGLE?

P.S. Does the Android version of FF4 support WebGL yet?

Regards

-Mark





Attachment: aquarium-bad.jpg
Description: JPEG image

begin:vcard
fn:Mark Callow
n:Callow;Mark
org:HI Corporation;Graphics Lab, Research & Development
adr:Higashiyama 1-4-4, Meguro-ku;;Meguro Higashiyama Bldg 5F;Tokyo;;153-0043;Japan
email;internet:callow_mark@hicorp.co.jp
title:Chief Architect
tel;work:+81 3 3710 9367 x228
tel;fax:+81 3 5773 8660
x-mozilla-html:TRUE
url:http://www.hicorp.co.jp,  http://www.mascotcapsule.com
version:2.1
end:vcard