[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Public WebGL] Could not initialise shaders in Chromium



Hi Gregg!
Cool, it works with --enable-webgl -use-gl=desktop ! Why wasn't I able
to find that command on the internet?
I was just seeing --enable-webgl. Thank you!

So one problem solved and one remaining.



2010/9/6 Gregg Tavares (wrk) <gman@google.com>:
> Which version of Chromium?
> I'm using the Canary Build of Chrome (on Win7)
> http://tools.google.com/dlpage/chromesxs
> As of day version 7.0.514.0
> with these options
> --enable-webgl -use-gl=desktop
> And both links work for me.
>
> On Mon, Sep 6, 2010 at 1:37 PM, M.Sirin <m.sirin07@googlemail.com> wrote:
>>
>> Hi,
>> got some errors when opening a webgl-page like
>> http://learningwebgl.com/lessons/lesson03/index.html in Chromium
>> 7.0.507.0 (57653): "could not initialise shaders".
>> for example on http://www.ibiblio.org/e-notes/webgl/ethanol.html i
>> just see a blue canvas.
>>
>> Then another issue with firefox. But in this case it is obviously my
>> fault:
>>
>> ERROR: 0:42: 'assign' :  cannot convert from 'const mediump int' to
>> 'varying mediump 3-component vector of float'
>> ERROR: 1 compilation errors.  No code generated.
>>
>> and then the second alert: "could not initialise shaders".
>>
>> After refreshing the site no errors occur and everything works fine in
>> Firefox.
>>
>>
>> You know why?
>>
>>
>> regards
>> -----------------------------------------------------------
>> You are currently subscribed to public_webgl@khronos.org.
>> To unsubscribe, send an email to majordomo@khronos.org with
>> the following command in the body of your email:
>>
>
>

-----------------------------------------------------------
You are currently subscribed to public_webgl@khronos.org.
To unsubscribe, send an email to majordomo@khronos.org with
the following command in the body of your email: