[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Public WebGL] Re: [3D Web] Future OpenGL ES semantics



On Wed, May 26, 2010 at 01:12, Vladimir Vukicevic <vladimir@mozilla.com> wrote:
>On Tue, May 25, 2010 at 21:51, Chris Marrin <cmarrin@apple.com> wrote:
>> If necessary
>> we can change the name of the texImage2D calls that take HTML objects. But
>> anything more would be a mistake, IMHO
>
> texImageHTML? :-)
>

I'm sorry to ask the obvious but how does renaming the function solve
any of the issues we are discussing ? :p
IMHO the name of the function is not the issue, the parameters we
choose to expose are, calling it by another name does not solve the
problems regarding presence or not of format selection and the
readability and extensibility problems of having two optional
booleans.

Doesn't having the same name to bridge HTML content actually makes
sense for a web-enabled binding to OpenGL ? It can be considered just
as another indirect boxed `data' parameter (exactly like texImage2D
with ArrayBuffer is an indirect boxed version of the void* native
version... or should we call the latter texImage2DArrayBuffer after
all?).


Regards,
-----------------------------------------------------------
You are currently subscribed to public_webgl@khronos.org.
To unsubscribe, send an email to majordomo@khronos.org with
the following command in the body of your email: