Template:Require

From OpenGL Wiki
Revision as of 16:58, 12 December 2014 by Alfonse (talk | contribs) (Undo revision 11631 by Alfonse (talk) Wrong page.)
Jump to: navigation, search

This template is used for inline citations of required OpenGL version numbers and/or extensions. It creates a phrase of the form "OpenGL <Version> or <Extension>". It takes 3 positional parameters:

  1. The OpenGL version number. If it's blank, the phrase "OpenGL <Version> or" won't be part of the text.
  2. The extension name. If it's blank, the phrase "or <Extension>" won't be part of the text.
  3. The prefix of the extension, as for Template:Extref. ARB extensions don't need one.

Examples:

Just OpenGL version {{require glsl|4.40}} GLSL 4.40
Just extension {{require glsl||shader_texture_image_samples}} ARB_shader_texture_image_samples
Both {{require glsl|4.50|shader_texture_image_samples}} GLSL 4.50 or ARB_shader_texture_image_samples