Results 1 to 9 of 9

Thread: 1.3 viewer

  1. #1
    Junior Member
    Join Date
    Jun 2005
    Posts
    4

    1.3 viewer

    Is there a 1.3 version of cviewer (in source or binary form) anywhere?

    All I can find on the site is a 1.2 viewer that hasn't been updated for 6 months ...

    Thanks,

    Adrian

  2. #2
    Senior Member
    Join Date
    Aug 2004
    Location
    California
    Posts
    771

    XSI Viewer

    The best COLLADA 1.3 viewer available is from Softimage. Download the XSI viewerand the XSI COLLADA plugin!

  3. #3
    Junior Member
    Join Date
    Jun 2005
    Posts
    4

    Needs XSI?

    The XSI Viewer itself seems unable to load Collada files.

    The manual in the Collada plugin says:

    "Copy the following files from the XSIViewerBin in the C:\users\<username>\Softimage\XSI_4.x\Application\ Plugins"

    and

    "You can access the COLLADA importer from the Plugins menu."

    Implying that XSI itself needs to be installed, i.e. the viewer is not standalone ?

  4. #4
    Junior Member
    Join Date
    Aug 2004
    Posts
    7
    I started by downloading the 1.3.1 plugin and the 3.6.2 version of the viewer and attempted to install them. After a bit of playing I realised that in fact you need the 3.6.3 version of the viewer which comes in the FTK which you need to download from here.

    Looking at the Manual html file in the plugin release I think that the viewer requires XSI to actually be installed:
    Copy the following files from the XSIViewerBin in the C:\users\<username>\Softimage\XSI_4.x\Application\ Plugins directory:
    which I thought could be a bit of a blocker for people without XSI.

    Fortunately I have a copy and so was able to move the specified files. I loaded the viewer and followed the instructions:
    You can access the COLLADA importer from the Plugins menu.
    In 3.6.2, I was unable to see a Plugins menu and Load on the File menu appeared to only support XSI files. I thought this might be a DLL issue, so I copied them to the viewer's bin directory and the global Application\Plugins directory, still to no avail.

    Using 3.6.3 I found a Plugins menu, but still no Collada plugin or options. In fact, you need to copy the required DLLs to the C:\Softimage\XSIFTK_3.6.3\bin\plugins\Custom directory to get them noticed. Once you get that done you can start using the viewer!

    Unfortunately, then I couldn't get any results from the files in the 1.2 release. I tried cube and collada.xml which resulted in nothing visible, and cylinder_man.xml which crashed the viewer.

    Anyone else having any better luck?

  5. #5
    Junior Member
    Join Date
    Aug 2004
    Location
    Montreal
    Posts
    20
    We have been doing some significant bug fixes for the past few weeks. We will post an update in the next few weeks as soon as we stabilize it and as soon as we come back from vacation. And we will separate the COLLADA plugin for XSI from the one for XSIViewer so that the installation procedure is clearer.

    Stay tuned. and thanks for your patience
    Alexandre Jean Claude
    Team lead - Pipeline and Data Management
    Softimage/AVID

  6. #6
    Junior Member
    Join Date
    Aug 2005
    Posts
    3
    Quote Originally Posted by rforster
    I started by downloading the 1.3.1 plugin and the 3.6.2 version of the viewer and attempted to install them. After a bit of playing I realised that in fact you need the 3.6.3 version of the viewer which comes in the FTK which you need to download from here.

    Looking at the Manual html file in the plugin release I think that the viewer requires XSI to actually be installed:
    Copy the following files from the XSIViewerBin in the C:\users\<username>\Softimage\XSI_4.x\Application\ Plugins directory:
    which I thought could be a bit of a blocker for people without XSI.

    Fortunately I have a copy and so was able to move the specified files. I loaded the viewer and followed the instructions:
    [quote:5rdar5mz]You can access the COLLADA importer from the Plugins menu.
    In 3.6.2, I was unable to see a Plugins menu and Load on the File menu appeared to only support XSI files. I thought this might be a DLL issue, so I copied them to the viewer's bin directory and the global Application\Plugins directory, still to no avail.

    Using 3.6.3 I found a Plugins menu, but still no Collada plugin or options. In fact, you need to copy the required DLLs to the C:\Softimage\XSIFTK_3.6.3\bin\plugins\Custom directory to get them noticed. Once you get that done you can start using the viewer!

    Unfortunately, then I couldn't get any results from the files in the 1.2 release. I tried cube and collada.xml which resulted in nothing visible, and cylinder_man.xml which crashed the viewer.

    Anyone else having any better luck?[/quote:5rdar5mz]

    thanks for the heads up, i did load some game asset in the XSI viewer 3.6.3. but the mesh was completely dark, this is normal i assume?I also loaded a free sample dotXSI scene into XSI and tried to export them , bought them into the 3.6.3 viewer , however it does load something, but it doesnt display it at all..maybe a graphics card driver issue? anyone can confirm this? try the "Jaiqua" sample: C:\Softimage\XSIFTK_3.6.3\Samples\Jaiqua_v36

    I just to confirm if basic animation and skinning is working properly in XSI, base on the 1.3 specs. Also the issue of UV maps is still not resolved with Collada and XSI?

    best regard,

    Sonk

  7. #7
    Junior Member
    Join Date
    Aug 2004
    Location
    Montreal
    Posts
    20
    There is a new update of the COLLADA converters both for XSI and the FTK 3.6.3, It fixes a few problems (hopefully the issues you have).

    http://www.collada.org/public_forum/viewtopic.php?t=230

    Do feel free to send me your problematic files if you still have issues and problems.

    Best regards.
    Alexandre Jean Claude
    Team lead - Pipeline and Data Management
    Softimage/AVID

  8. #8
    Junior Member
    Join Date
    Aug 2004
    Location
    Montreal
    Posts
    20
    Oh, and if you were using Jaiqua as the test, she will re-import all in black, because that model uses OpenGL realtime shaders which are not yet supported by the current version of the COLLADA converter.

    Hope that helps.
    Alexandre Jean Claude
    Team lead - Pipeline and Data Management
    Softimage/AVID

  9. #9
    Junior Member
    Join Date
    Aug 2005
    Posts
    3
    Quote Originally Posted by ajclaude
    There is a new update of the COLLADA converters both for XSI and the FTK 3.6.3, It fixes a few problems (hopefully the issues you have).

    http://www.collada.org/public_forum/viewtopic.php?t=230

    Do feel free to send me your problematic files if you still have issues and problems.

    Best regards.
    ajclaude,

    a quick question about the current collada specs with regards to UV map support. From what i understand, UVs map can be imported/exported only if a texture is applied? Ideally, i would like the UV maps to be transferable without needing to apply a texture to the mesh, kind of like what you can currently do with .obj file format. I hope this gets address in the future(if it isnt already).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •