Results 1 to 3 of 3

Thread: Maya plug-in build errors

  1. #1
    Junior Member
    Join Date
    Aug 2004
    Location
    SCEE, UK
    Posts
    9

    Maya plug-in build errors

    I've been building the Maya plug-in for Maya 6, as only a Maya 5 binary is included in the download.

    I've had to patch up the code a lot to get it to build under .NET 2003.

    The main change is that every use of xmlGetProp() requires a cast to (const xmlChar *) on the second element,
    e.g.
    xmlGetProp( source, (const xmlChar *)COLLADA_PROFILE_PROPERTY )

    I also get a lot of comparison signed/unsigned mismatch warnings and a load of float/double warnings.

    But with the errors fixed and the warnings ignored, it does all seem to work.

    Maybe these build problems could be fixed up before the next release.

    cheers,
    os.
    Andrew Ostler
    Senior Principal Programmer
    SCEE

  2. #2
    Junior Member
    Join Date
    Sep 2004
    Location
    Alias, Toronto, CA
    Posts
    11
    Guilty as charged Os - thanks for the details on the build error (obviously I don't build on that version here). I'll try and get a version out which behaves itself a little better soon.

  3. #3
    Junior Member
    Join Date
    Sep 2004
    Location
    Alias, Toronto, CA
    Posts
    11
    Just FYI - there's a new version of the Maya translator linked off the Maya announcements page - it should address the build problems on .net 2003.

    Cheers,
    G

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •