Results 1 to 3 of 3

Thread: Invalid device error on second video card.

  1. #1
    cymick
    Guest

    Invalid device error on second video card.

    I'm getting an invalid device error when I try to create my command queue using my second video card. I have two Radeon HD 5800 series video cards (crossfire is off) and I only get this error with the second card. The program runs just fine on the first. I've looked into the AMD control center on my pc (windows 7 operating system) and it says the second cards adapter is disabled. How do I correct this? If it's just a matter of enabling the card adapter how is that done? I've looked around a bit and haven't had any luck with this.

  2. #2
    chippies
    Guest

    Re: Invalid device error on second video card.

    First, check in Device Manager if the card is enabled, if not then enable it there. Additionally, you might need to extend your Windows desktop onto the second card - that does require connecting it to a display.

  3. #3
    cymick
    Guest

    Re: Invalid device error on second video card.

    I figured out the issue. I was selecting the device correctly but I wasn't passing the device id correctly to clCreateContext.

Similar Threads

  1. more than 1 read_only image2d_t freezes video card
    By Yours3lf in forum OpenCL - parallel programming of heterogeneous systems
    Replies: 0
    Last Post: 03-01-2012, 09:55 AM
  2. OpenML Video card.
    By halayli in forum OpenML Coding & Technical Issues
    Replies: 1
    Last Post: 03-01-2005, 11:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •