Hello

I am trying to get an older C++ project working on a newer version of Ubuntu. (This project works as expected on an older unsupported Ubuntu version). I have successfully built the COLLADA dom, fx and rt libs. To test my build, I also built the included viewer application and it is successfully able to load and render my model. However on the older project, I am running into the following error -

"COLLADA_DOM Load Started models/Square/models/model.dae
Error: Document is empty

Error: Error parsing XML in daeLIBXMLPlugin::read

Error: Failed to load file:/models/Square/models/model.dae

Error loading the COLLADA file models/Square/models/model.dae make sure it is COLLADA 1.4 or greater
Failed to read scene "

I have double checked the existence of the file and as I have mentioned my viewer application is able to successfully load the same model. Any suggestions on the source of the error would be highly appreciated. At a guess, I am thinking that my older project is using a different version of some particular library that throws the error. Thanks in advance.