Results 1 to 3 of 3

Thread: Linux 64 bit ? Linking colladadom with shared boost version 1.52

  1. #1
    nickyp
    Guest

    Linux 64 bit ? Linking colladadom with shared boost version 1.52

    When i link colladadom against boost 1.52 it errors out with lack of -fPIC for the boost static *.a libraries.

    How can i set up colladadom to link against *so (shared) libraries?

  2. #2
    samxim
    Guest
    I am not sure you can ask someone IT or google.com. Hope give you a hand~

  3. #3
    nickyp
    Guest
    else
    debug_suffix = ""
    endif
    -libOpts += stage/packages/lib/$(conf)/libboost_system-mt$(debug_suffix).a
    -libOpts += stage/packages/lib/$(conf)/libboost_filesystem-mt$(debug_suffix).a
    +#libOpts += stage/packages/lib/$(conf)/libboost_system-mt$(debug_suffix).a
    +#libOpts += stage/packages/lib/$(conf)/libboost_filesystem-mt$(debug_suffix).a


    # minizip
    includeOpts += -Iexternal-libs/minizip/include
    -libOpts += -Lbuild/$(buildID)-$(colladaVersion)$(debugSuffix)/
    -libOpts += -lminizip$(debugSuffix)
    +#libOpts += -Lbuild/$(buildID)-$(colladaVersion)$(debugSuffix)/
    +#libOpts += -lminizip$(debugSuffix)
    # as we link minizip static on osx, we need to link against zlib, too.
    ifeq ($(os),mac)
    libOpts += -lz

    then added -shared to LDFLAGS

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •