Results 1 to 2 of 2

Thread: Missing Vertex-Indices

  1. #1
    Junior Member
    Join Date
    Mar 2010
    Posts
    4

    Missing Vertex-Indices

    Hi,

    i try to write a collada loader in java. I installed the latest OpenCOLLADA exporter for 3ds max to export my models. But in the exported file the indices for the vertices are missing.

    For example if i export only one triangle i get this:

    Code :
    ...
        <geometry id="geom-Plane01" name="Plane01">
          <mesh>
            <source id="geom-Plane01-positions">
              <float_array id="geom-Plane01-positions-array" count="9">-16.23616 -15.86716 0 16.23616 -15.86716 0 16.23616 15.86716 0</float_array>
              <technique_common>
                <accessor source="#geom-Plane01-positions-array" count="3" stride="3">
                  <param name="X" type="float"/>
                  <param name="Y" type="float"/>
                  <param name="Z" type="float"/>
                </accessor>
              </technique_common>
            </source>
            <source id="geom-Plane01-map1">
              <float_array id="geom-Plane01-map1-array" count="24">0 0 0 1 0 0 0 0 0 1 0 0 0 0 0 1 0 0 0 1 0 1 1 0</float_array>
              <technique_common>
                <accessor source="#geom-Plane01-map1-array" count="8" stride="3">
                  <param name="S" type="float"/>
                  <param name="T" type="float"/>
                  <param name="P" type="float"/>
                </accessor>
              </technique_common>
            </source>
            <vertices id="geom-Plane01-vertices">
              <input semantic="POSITION" source="#geom-Plane01-positions"/>
            </vertices>
            <triangles material="ColorMaterial" count="1">
              <input semantic="VERTEX" source="#geom-Plane01-vertices" offset="0"/>
              <input semantic="TEXCOORD" source="#geom-Plane01-map1" offset="1" set="1"/>
     
     
    5 7 4</p>
            </triangles>
          </mesh>
        </geometry>...

    As you can see there are only the indices for the texture coordinates (

    5 7 4</p>
    ). I looked at the collada specification and it should be something like that

    0 5 1 7 2 4</p>
    .

    I also tried out the autodesk collada exporter for 3ds max and there the indices are correct.

    thx Marc

  2. #2
    Junior Member
    Join Date
    Mar 2010
    Posts
    4

    Re: Missing Vertex-Indices

    I found the problem. It's a bug in the exporter plugin. Now i have activated the export of normals an now the indices of the vertices appears in the exported file.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •