Results 1 to 4 of 4

Thread: Setting up skeletal animation using COLLADA DOM.

  1. #1
    Junior Member
    Join Date
    Jan 2010
    Posts
    10

    Setting up skeletal animation using COLLADA DOM.

    Hi everyone,

    I'm a novice about collada dom. By now I have down loaded it and figured out how the viewer works. I was wondering if it's possible to set up some simple skeletal animation using COLLADA DOM and where should I look into. I have no idea about how to do it ,maybe I can load a .dae with some animation embedded and change it afterward, or maybe I can make the new animation combined with OpenGL.

    I tried to find some methods in <node> and find the LocalToWorldMatrix. But I cannot figure out any differences when I changed them randomly.
    I am exported my model with armature (COLLADA 1.4) from blender. Sorry for any stupid questions.Any help will be appreciated.

    Cheers
    Ray

  2. #2
    Junior Member
    Join Date
    Jan 2010
    Posts
    10

    Re: Setting up skeletal animation using COLLADA DOM.

    I tried made some animation using Blender and this time the collada dom said :

    Add new Animation Forearm-rotateX
    Animation source Forearm-rotateX-interpolation is not support
    Animation target target=Forearm/rotateX.ANGLE can not be solved
    No Channel found in this animation

    Could somebody help please. Is it possible to set up some animation using this powerful tool and where I should take a look .

  3. #3
    Senior Member
    Join Date
    Aug 2004
    Location
    California
    Posts
    771

    Re: Setting up skeletal animation using COLLADA DOM.

    Can you post your .dae file that you got from Blender so people can examine it?

  4. #4
    Junior Member
    Join Date
    Jan 2010
    Posts
    10

    Re: Setting up skeletal animation using COLLADA DOM.

    Quote Originally Posted by marcus
    Can you post your .dae file that you got from Blender so people can examine it?
    Hi Macrus,

    Really exciting to see your reply. I have attached the latest one I got.

    I figured out the reason that the animation cannot be loaded appropriately is because the "Bake Matrices" option need to be disabled when export the .dae file.
    And the animation is working only for skeleton now. But the mesh is not deforming.
    Would you please let me know if it is possible to setup the animation by changing the LW matrix of the node and where should I look into?

    The help is very much appreciated. Thanks in advance.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •