Results 1 to 4 of 4

Thread: Bad rendering

  1. #1
    Junior Member
    Join Date
    Apr 2009
    Posts
    2

    Bad rendering

    Hi,

    I created a model in 3dstudioMAX 9 and exported it to DAE with the feelingsoftware collada MAX plugin. Then I import it into papervision3D and the model shows fine. However, it seems not to render correctly, as if it displaces the faces. Please take a look at the picture below to clearify this



    I tried different modeling techniques but they both behave the same in papervision.
    What is going on?

  2. #2

    Re: Bad rendering

    It's difficult to get the required information out from a screenshot So either please provide the 3ds Max file or the DAE. Did you already try it with the "NextGen" plugins that are available at http://sf.net/project/showfiles.php?...kage_id=303397 ? Tangents and Binormals are not the problem here but if you don't need them leave the option unchecked to reduce file size.

  3. #3
    Junior Member
    Join Date
    Apr 2009
    Posts
    2

    Re: Bad rendering

    Hi,

    thanks for the tip. I hadn't tried that one yet, however it gives me the same results.
    You can have a look at the files here

  4. #4
    Yavin
    Guest

    Re: Bad rendering

    Hey m6246,

    I had a brief look at your files and got your Test.as run with FDT. First issue I recognized is that you use the "org.papervision3d.objects.parsers.Collada" parser. In my first papervision code I used "org.papervision3d.objects.parsers.DAE". I swapped the parser and the rendering seems to be different (especially the scale of the scene). I don't know why there are two parsers for COLLADA but based on the comments in the source I assume the "org.papervision3d.objects.parsers.Collada" parser is a new one which is yet not finished. Try it with "org.papervision3d.objects.parsers.DAE".

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •