Page 1 of 5 12345 LastLast
Results 1 to 10 of 48

Thread: maya 8.5: // Error: does not match the current architecture

  1. #1

    maya 8.5: // Error: does not match the current architecture

    When I try to load the collada plugin in maya 8.5 on my macbook pro (intelmac UB), the output window says:

    // Error: does not match the current architecture (COLLADA_m85)

    Does anyone have this problem, does someone know a work around or sollution?

    I remember dat the same error occors when trying to load the vector renderer in maya which is an intelmac problem.. The weird thing is that the collada feelings software company which makes the maya plugin specifically says it works on intel and maya 8.5!!

    quote from their website:
    The binary provided is for Maya 8.5 only, and has been compiled in universal mode so that it can run on PowerPC and Intel machines equally. ... ablePlugin

    please help 'cause my deadline is coming!!

  2. #2
    Senior Member
    Join Date
    Jan 2006
    Foster City, CA
    Unfortunately I don't have an answer for you, or an Intel Mac to test on.

    It's possible if you post in Feeling's forum they'll be able to help, but as I understand it they're not going to be working on or supporting the open source stuff anymore; they'll only be supporting their 'premium' plugins which you have to pay for. The free plugins will be picked up and maintained by SCEA and Intel, but the details of that are still being worked out so there's nobody dedicated to fixing problems in the free version at the moment.

    Probably the best solution is to grab the code from Sourceforge and build it yourself, which should get you working binaries.


  3. #3
    The Maya 8.5 version should work on the Mac, however I don't have a Maya 8.5 setup to test it on right now.

    Originally, there were some problems with the install script not copying the plugin to the right directory but I thought those were fixed.

    Have you tried the latest version of the plugin 3.05b? There were some changes to the install scripts for that one.

  4. #4
    thanx for the reply, I've placed the plugin in the following directory: Users/shared/autodesk/8.5/plug-ins

    the plug-in shows up in maya but when I try to activate the checkbox in the plug-in manager it gives the error:

    // Error: does not match the current architecture (COLLADA_m85)

    I've installed the Cg 1.5 stuff from nvidia and double checked all my directories for the AETemplates files , collada files and the .xpm!

  5. #5
    Hi siebejanssen,

    You didn't say which version of the plugin you are using, I need to know that.

    If you are not using 3.05b from or from here ... _id=136478 please get it and give it a try.

    In the meantime I will check the setup of my Mac and see if I can find any more information for you about the problem. I have 3.05b working on Maya 2008, I rebuilt the plugin, but that was mainly because a 2008 version wasn't in the package at the time.

  6. #6
    I've installed the ColladaMaya_OSX_3-1.05B.. Thanks a lot for helping me!

  7. #7

    Were you able to resolve the error?

    I also have this error and looking for a solution, please post an answer here if you find one and I'll do the same.


  8. #8
    It sounds like getting the latest release of ColladaMaya fixed it for him mal80...if it doesn't work for you please let me know.

  9. #9
    Installing the latest version did NOT solve the error! mal80. I already installed the latest version before I posted this problem.

    "I've installed the ColladaMaya_OSX_3-1.05B.. Thanks a lot for helping me!"

    was a reply to greg_corson's question:

    "You didn't say which version of the plugin you are using, I need to know that."

    Hope I made that clear..

    I've read that installing cg 1.5 sometimes helps, but it didn't for me..

    I've also tried using the fbx converter from autodesk but it doesn't output the right .dae construction used for papervision. I'm testing an application called meshlab which is free, can output collada files and looks promising. I can import the geometry vertices into papervision but now the material attributes are missing in the dae file!! Well.. at least the geometry loads.. so I guess it's a start.. I just don't understands why the material doesn't output..

    More help is more than welcome!

  10. #10
    Terribly sorry for the misunderstanding....I'm installing maya 8.5 now so I can test this on my machine.

    One possible problem is that the plugin got installed with incorrect permissions, I have seen this happen on some systems.

    While I'm doing testing, please give this a try....

    Use spotlight to search for COLLADA.bundle, hold down the apple key and click on COLLADA.bundle in spolight menu to open a finder window. (or you can just browse through the finder to Users/shared/autodesk/8.5/plugins)
    Do a "get info" on COLLADA.bundle
    Check the permissions part of the "get info" dialog. If your account or "everyone" doesn't show up with read access, this may be your problem. You should be able to change the permissions from "get info" dialog.

    Just click the little lock icon at the bottom of the window, then select "everyone" from the permissions list and change the permissions to "read only" or "read and write" If your account is on the list, do the same thing for it.

    Then try loading the plugin in maya from the plugin manager.

    Please let me know if this works for you...I'm doublechecking this in the package now to see if the current version installs this way.

Page 1 of 5 12345 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts