Results 1 to 7 of 7

Thread: Collada 1.4 - Blender 2.41a - Export Textures

  1. #1
    Junior Member
    Join Date
    Sep 2006
    Posts
    2

    Collada 1.4 - Blender 2.41a - Export Textures

    I installed the 0.3.108 Collada Import/Export V 1.41 in Blender V2.41a. When I export my model (that contains texture/images) the resultant .dae file does not contain any texture information. The .dae file has no <library_images> at all. I searched the whole .dae file and can find no reference to ".jpg" or "image".
    Is there something I am forgetting to do?
    Thanks for any help on this.

  2. #2
    Senior Member
    Join Date
    Jul 2004
    Location
    Santa Clara
    Posts
    356
    I've heard a lot of issues regarding texturing in Blender. It seems there is some magic to assign texture to polygons.
    Could someone using Blender give us the recipe ?

  3. #3
    Senior Member
    Join Date
    Jan 2006
    Location
    Foster City, CA
    Posts
    540
    This doesn't help much, but If I take the default Blender scene and add an image texture to the cube and export, I get <texture> and <image> elements in the exported document. Of course it's not in the texture->sampler->surface->image style, and also the <texture> is missing the "texcoord" attribute. But there is texture data exported.

  4. #4
    Member
    Join Date
    Dec 2004
    Location
    SCEA, Foster City
    Posts
    36
    There is a bug tracker here:

    http://colladablender.illusoft.com

    I added your issue, you can see it here:
    http://colladablender.illusoft.com/mant ... .php?id=65

    Isn't there a textured cube included in the exporter? Does that work at all?

  5. #5
    Senior Member
    Join Date
    Jul 2004
    Location
    Santa Clara
    Posts
    356
    Quote Originally Posted by sthomas
    ...add an image texture to the cube ...
    Can you describe what you do to do this operation in blender, I think there may be several ways of doing this in Blender, some work, some don't.

  6. #6
    Junior Member
    Join Date
    Sep 2006
    Posts
    2

    Solution

    Thanks for the responses!

    After much trial and error I discovered the solution.

    1 - You must have the latest Collada fo Blender (v0.3.10
    2 - You must have Blender V2.42a
    3 - You must have Python 2.43 (later versions do not work with ColladaBlender export)
    I had to reinstall Python 2.43 after reistalling Blender and new Collada export.

    I am using the export function to create KMZ file for Google Earth. The export settings for this are:
    -File / Export / Collada V1.4
    -Select Triangles, Disable Physics, Use Relative Paths (Do not select Use UV Image)

    Nevertheless, all textures exported must be UV mapped (RGB textures are not exported). To maintain relative paths the image used in the texture must be located (and imported in Blender) from a folder called "images" located in the same directory as the Blender file.

    If you would like a working example of this, e-mail me: nhirsig@tufts.edu
    I will send you an attached .kmz file (you can unzip) that contains a .dae exported from Blender (in "models" folder), an image file (used for the UV mapping stored in an "images" folder), A textures.txt file (associating the texture file) and the KML file that opens Google Earth and calls the other files to be displayed in Google Earth at logitude and lattitude. I can also send you the associated .blend file to open in Blender.

    Neal Hirsig

  7. #7

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •