Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: error on load, no shading in maya 7.0

  1. #11
    Senior Member
    Join Date
    Aug 2004
    Location
    California
    Posts
    771
    Quote Originally Posted by bobby_newmark
    Well, I'm getting concerned now:
    I installed the new 2.00 ColladaMaya on my box today. I tried the new test cases included in the distribution: same trouble as before.
    Are those test files actually changed with their new release?

  2. #12
    Are those test files actually changed with their new release?
    Yep, they did change from 0.90. However, as stated above, I also tested with the collada DOM distribution's samples, with the same effect.

  3. #13
    I tried the whole thing now on another machine, just to be sure.

    The result is the same - neither the testsuite coming with colladaMaya 2.0 nor the samples int the collada DOM distribution that habe colladaFX portions in it work, they're still all black or green.

    I tested in an AMD 64 X2 4200+ with an NVIDIA 7600GS graphics board. Again, freshly installed Maya 7.0, cg Toolkit 1.5 beta (made sure its DLLs are in Maya's bin directory so it doesn't load the preinstalled old versions), and the ColladaMaya 2.0 plugin.

    I also ran the examples that come with the cg toolkit, they work fine on my machine as well (so it's not that cg stuff doesn't work in general on my box).

    Here is an excerpt of the command console output while I was loading one testcase/sample after the other:

    [...]
    pv_performAction "C:/Xtract/collada_dom_path3/COLLADA_DOM/samples/data/COLLADA/multimtl.dae" "Best Guess";
    file -f -typ "COLLADA importer" -o "C:/Xtract/collada_dom_path3/COLLADA_DOM/samples/data/COLLADA/multimtl.dae";addRecentFile("C:/Xtract/collada_dom_path3/COLLADA_DOM/samples/data/COLLADA/multimtl.dae", "COLLADA importer");
    connectAttr -f redMaterial.outColor redMaterialSG.surfaceShader;
    connectAttr -f blueMaterial.outColor blueMaterialSG.surfaceShader;
    // Result: 1 //
    pv_performAction "C:/Xtract/collada_dom_path3/COLLADA_DOM/samples/data/COLLADA/mushroom140.dae" "Best Guess";
    file -f -typ "COLLADA importer" -o "C:/Xtract/collada_dom_path3/COLLADA_DOM/samples/data/COLLADA/mushroom140.dae";addRecentFile("C:/Xtract/collada_dom_path3/COLLADA_DOM/samples/data/COLLADA/mushroom140.dae", "COLLADA importer");
    // Result: 1 //
    pv_performAction "C:/Xtract/collada_dom_path3/COLLADA_DOM/samples/data/COLLADA/mushroom_durer.dae" "Best Guess";
    file -f -typ "COLLADA importer" -o "C:/Xtract/collada_dom_path3/COLLADA_DOM/samples/data/COLLADA/mushroom_durer.dae";addRecentFile("C:/Xtract/collada_dom_path3/COLLADA_DOM/samples/data/COLLADA/mushroom_durer.dae", "COLLADA importer");
    // Result: 1 //
    pv_performAction "C:/Xtract/collada_dom_path3/COLLADA_DOM/samples/data/COLLADA/mushroom_plastic.dae" "Best Guess";
    file -f -typ "COLLADA importer" -o "C:/Xtract/collada_dom_path3/COLLADA_DOM/samples/data/COLLADA/mushroom_plastic.dae";addRecentFile("C:/Xtract/collada_dom_path3/COLLADA_DOM/samples/data/COLLADA/mushroom_plastic.dae", "COLLADA importer");
    // Result: 1 //
    select -r Mushroom_resting2 ;
    pv_performAction "C:/Xtract/collada_dom_path3/COLLADA_DOM/samples/data/COLLADA/mushroom_plastic.dae" "Best Guess";
    file -f -typ "COLLADA importer" -o "C:/Xtract/collada_dom_path3/COLLADA_DOM/samples/data/COLLADA/mushroom_plastic.dae";addRecentFile("C:/Xtract/collada_dom_path3/COLLADA_DOM/samples/data/COLLADA/mushroom_plastic.dae", "COLLADA importer");
    // Result: 1 //
    pv_performAction "C:/Xtract/collada_dom_path3/COLLADA_DOM/samples/data/COLLADA/mushroom_wigglatexadescent.dae" "Best Guess";
    file -f -typ "COLLADA importer" -o "C:/Xtract/collada_dom_path3/COLLADA_DOM/samples/data/COLLADA/mushroom_wigglatexadescent.dae";addRecentFile("C:/Xtract/collada_dom_path3/COLLADA_DOM/samples/data/COLLADA/mushroom_wigglatexadescent.dae", "COLLADA importer");
    // Result: 1 //
    [...]

    One thing that does strike me is the 'Result: 1' comment after each load command - does that mean 'true - all ok' or is it like a C std library return (not equal to zero implies error)

    Anyways, I'm not really keen on debugging the plugin to find out what's wrong, does anyone have any more clues for me what I could try?

    Cheers,

    Uwe

  4. #14
    Senior Member
    Join Date
    Apr 2005
    Location
    Feeling Software, Montreal, Quebec
    Posts
    111
    Hi Uwe,

    I've been working on usability and stability for the ColladaFX render node, this week. I'm going to make a service-release, tomorrow, with the modifications that I've done to improve the ColladaFX render node, as well as a number of fixes requested by users.

    Please try the new version, tomorrow. If you still experience issues: email us directly at colladamaya@feelingsoftware.com.

    Sincerely,
    Guillaume Laforte
    Feeling Software Inc
    http://www.feelingsoftware.com

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •