Results 1 to 4 of 4

Thread: Max Plugin Y-Up doesnt work with bone/skin transformations

  1. #1
    Junior Member
    Join Date
    Jan 2006
    Posts
    15

    Max Plugin Y-Up doesnt work with bone/skin transformations

    Well im fed up with trying to get my animations exported using the Max Collada plugin to look right in OpenGL. I agree my math skills are not good enough to get it working.

    I understand that the Y-up option is still experimental and currently it exports vertices perfectly. Normals appear to have problems.

    Bone transformations dont seem to be affected at all by the option.

    Im wasting too much time trying to get my animations work because of the different coordinate systems. Could i request the Max plugin developers to give me an idea on when they plan to get the Y-Up option working, so that i can work on other parts of my project.

  2. #2
    Senior Member
    Join Date
    Apr 2005
    Location
    Feeling Software, Montreal, Quebec
    Posts
    111
    Don't use the "Y-up" export option in 3dsMax. Don't use ANY of the "Experimental" export options: they are broken and will often give bad results. Please read the release note for more information on this. Right now, we have no plans to fix the "Y-up" export option. I personally think its causing too much pain and should be removed.

    Using a "Z-up" world is not hard, in OpenGL: you just have to adapt your camera. If you also use Maya objects, tell your artists to change their settings and use Z-up.

    If you must load your "Z-up" oriented objects within a "Y-up" world, then you should switch all the Z and the Y values for transformations, vertex normals, vertex positions. You also have to remember to attach the animation curves differently. There may also be a -1 factor to add to the Y coordinates.

    There's an easy way to do this, within Max: move your camera to point straight down on the plane and re-orient your skinned character to animate as if the Y-axis was up. The camera controls are harder to use, but you'll get what you want.

    Sincerely,
    Guillaume Laforte
    Feeling Software Inc
    http://www.feelingsoftware.com

  3. #3
    Junior Member
    Join Date
    Apr 2006
    Posts
    4
    It's really a pity this is not going to change. I don't know how the exporter works exactly, but maybe you can transform the object in max with maxscript before doing the export and after the file is written undo the transform. This is perhaps 2 or 3 lines and does exactly what you propose to do manually. The maxscript way is much easier for everybody + it will take care of transforming everything, even animations and you don't need to switch the components manually while importing.
    What do you think?

    -Matthias

  4. #4
    Junior Member
    Join Date
    Apr 2006
    Posts
    3
    I'll add my vote in favour of a functioning y-up option as well. Otherwise I'll need to rotate all my models in max before exporting. It works, but it's a hassle.

    I'd also like to request a Max 7 version of the latest 2.10 exporter if possible. Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •