Khronos Public Bugzilla
Bug 828 - Annotate WD -- Spec needs to Define What Versions of OpenCL are Supported --
Annotate WD -- Spec needs to Define What Versions of OpenCL are Supported --
Status: RESOLVED FIXED
Product: WebCL
Classification: Unclassified
Component: Specification
1.0
All All
: P3 normal
: ---
Assigned To: WebCL Mailing List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-13 15:57 PDT by steven eliuk
Modified: 2013-03-18 06:57 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description steven eliuk 2013-03-13 15:57:22 PDT
During the meetup on 03-13-13 the WG agreed the WD needs to define what versions of OpenCL are supported {1.1, 1.2, {embedded and full}}. Likewise, make the statement that the WebCL API is based on 1.1 embedded,

Please close this bug once the WD is updated to reflect this,
Comment 1 Tomi Aarnio 2013-03-18 06:57:24 PDT
Added the following paragraph in a new chapter called "Implementation notes":

 "Although WebCL is based on OpenCL 1.1 (Embedded Profile), it can
  also be implemented on top of OpenCL 1.2, or any future version
  that remains backwards compatible with OpenCL 1.1."