Khronos Public Bugzilla
Bug 792 - Integration of WebCL prototype in Mozilla Firefox engine
Integration of WebCL prototype in Mozilla Firefox engine
Status: RESOLVED LATER
Product: WebCL
Classification: Unclassified
Component: Sample Implementation
1.0
All All
: P3 normal
: ---
Assigned To: WebCL Mailing List
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-08 16:23 PST by Tasneem Brutch
Modified: 2014-04-09 11:14 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tasneem Brutch 2013-02-08 16:23:41 PST
To track the effort to integrate Nokia's WebCL prototype into Firefox
Comment 1 Tasneem Brutch 2013-02-08 17:03:06 PST
Adding the previous emails for background;

-----Original Message-----
From: owner-webcl@khronos.org [mailto:owner-webcl@khronos.org] On Behalf Of Jeff Gilbert
Sent: Thursday, January 31, 2013 3:26 PM
To: Fabien Cellier
Cc: webcl@khronos.org; Tomi Aarnio
Subject: [WebCL] Re: MQ for firefox?


WebCL code is probably best placed near the WebGL code. Since WebCL isn't Canvas-based like WebGL, it should probably go in /content/webcl.

-Jeff

----- Original Message -----
From: "Fabien Cellier" <fabien.cellier@gmail.com>
To: "Tomi Aarnio" <tomi.aarnio@nokia.com>, "Jeff Gilbert" <jgilbert@mozilla.com>
Cc: webcl@khronos.org
Sent: Thursday, January 31, 2013 3:15:44 PM
Subject: MQ for firefox?

Hi Tomi, 

It is hard to integrate a big code directly in firefox, it is easier to submit many small patches. So the idea is to have 2 repos,one in the project repo and the other one is the mq (mq is only patches that you can easily add/remove : https://developer.mozilla.org/en-US/docs/Mercurial_Queues ) 

I know it's a little redundant but it will be easier for us to ask webCL integration and it will help firefox reviewers. 


I think your code should be in /dom(/src) or /content (and if we add it to window, it will be a little easier to integrate it in webworker). Futhermore, there was some changes in the trunk : 


public typedArray API have changed (no context anymore) JS_*RootScope are deprecated ( no more "root as you go", so we should think if there is other changes with the new GC) 

regards, 
fabien
Comment 2 Tomi Aarnio 2013-03-07 03:45:20 PST
We’re now able to build Firefox with WebCL patched in as an XPCOM component under browser/components/webcl. 

This is the easiest and most “shallow” kind of integration – we can generate a patch automatically from the WebCL extension codebase, but on the flipside, we can’t get WebGL integration. 
 
The biggest difficulty for us has been that the mozilla-central codebase appears to be broken quite often – it fails to build, even without WebCL. Maybe we’re missing something? Is there some way to know which changesets are in working condition? Is it more likely for a build to fail if we have disabled things like Ogg, Dash, WebM, crashreporter and accessibility in mozconfig?
 
Anyhow, we’d be ready to push our code to the projects/webcl repo. Fabien, are you OK if we wipe out your old code and replace it with the new, or shall we set up a separate branch?
Comment 3 Tomi Aarnio 2013-04-04 08:11:28 PDT
I’ve just pushed our WebCL codebase to http://hg.mozilla.org/projects/webcl, integrated with mozilla-central trunk, and confirmed that it builds on at least Scientific Linux 6.0 (64-bit).

There was a minor complication, though – I had to add “CLOSED TREE” to the commit message to avoid getting rejected by something called ‘treestatus’. Any advice on how to resolve that in a nicer way?

Now, how should I proceed to get nightly/weekly builds running on Mozilla build servers?
Comment 4 steven eliuk 2013-11-04 13:36:33 PST
Tomi mentioned that "it was pointed out before, there’s no WebCL code in mozilla-central. It’s in the Mozilla “projects” repo".
Comment 5 Tomi Aarnio 2014-04-08 23:45:35 PDT
Closing this ticket as RESOLVED LATER because at the moment there's no Firefox integration effort underway. 

We could, of course, do unofficial Firefox builds with WebCL integrated, but that would be much less convenient for users than the currently available add-on.
Comment 6 James Riordon 2014-04-09 11:14:50 PDT
Closing this ticket as RESOLVED LATER because at the moment there's no Firefox
integration effort underway. 

We could, of course, do unofficial Firefox builds with WebCL integrated, but
that would be much less convenient for users than the currently available
add-on.