Khronos Public Bugzilla
Bug 499 - Consistency in function names get_global_size, get_local_size, and get_num_groups
Consistency in function names get_global_size, get_local_size, and get_num_gr...
Status: NEW
Product: OpenCL
Classification: Unclassified
Component: Specification
unspecified
All All
: P3 enhancement
: ---
Assigned To: Aaftab Munshi
OpenCL Working Group
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-23 19:17 PDT by Sean Settle
Modified: 2011-07-23 19:17 PDT (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sean Settle 2011-07-23 19:17:32 PDT
The functions get_global_id, get_local_id, and get_group_id follow a consistent naming scheme.  Please make the naming scheme for the corresponding size/num functions, either
A) get_global_size, get_local_size, and get_group_size,
or
B) get_num_globals, get_num_locals, and get_num_groups.