Khronos Public Bugzilla
Bug 368 - WFCT_Utils_testElementBooleanAttrib: incorrect checking of invalid parameter setting
WFCT_Utils_testElementBooleanAttrib: incorrect checking of invalid parameter ...
Status: RESOLVED DUPLICATE of bug 367
Product: OpenWF
Classification: Unclassified
Component: Conformance Tests
unspecified
All All
: P3 normal
: ---
Assigned To: Robert Palmer
Composition work group email alias
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-22 04:45 PDT by Cyril PROTAT
Modified: 2010-11-09 06:07 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cyril PROTAT 2010-10-22 04:45:38 PDT
In the wfc_test_utils.c file, the function "WFCT_Utils_testElementBooleanAttrib" tests the setting of an incorrect parameter : 

[ wfc_test_utils.c, line 224]

"/* Set bad handle (float) */"
wfcSetElementAttribf(appCtx->dev, WFC_INVALID_HANDLE, attrib, expectedf);
WFCT_CHECK_ERROR(WFC_ERROR_BAD_ATTRIBUTE, "Raised wrong or no error for bad handle (float setter).");
valuef = wfcGetElementAttribf(appCtx->dev, WFC_INVALID_HANDLE, attrib);
WFCT_CHECK_ERROR(WFC_ERROR_BAD_ATTRIBUTE, "Raised wrong or no error for bad handle (float getter).");

The return code for such an invalid attribute (WFC_INVALID_HANDLE) should be (and actually is) WFC_ERROR_BAD_HANDLE, not WFC_ERROR_BAD_ATTRIBUTE as in the above code.
Comment 1 lars.f.persson 2010-11-09 06:07:20 PST
Duplicate of 367

*** This bug has been marked as a duplicate of bug 367 ***