Khronos Public Bugzilla
Bug 357 - missing GL_EXT_direct_state_access definitions in glext.h
missing GL_EXT_direct_state_access definitions in glext.h
Status: RESOLVED FIXED
Product: OpenGL
Classification: Unclassified
Component: Registry
unspecified
All All
: P3 normal
: ---
Assigned To: Jon Leech
:
: 626 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-09 14:37 PDT by alexbolz
Modified: 2013-06-13 03:46 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description alexbolz 2010-09-09 14:37:35 PDT
The current glext.h (Date: 2010-08-03 01:30:25 -0700 (Tue, 03 Aug 2010))
and gl.spec files do not contain the definitions related to vertex array
objects as defined in the GL_EXT_direct_state_access extension
specification (lines 1053 ff.)
Comment 1 Nicolas Lelong 2012-08-09 14:47:00 PDT
*** Bug 626 has been marked as a duplicate of this bug. ***
Comment 2 Nicolas Lelong 2012-08-09 14:47:42 PDT
Would submitting a patch help fixing this long standing issue ?
Comment 3 Jon Leech 2013-06-13 03:46:29 PDT
This should be fixed in the new XML API Registry and in the
headers generated from that; see

http://www.opengl.org/registry/#specfiles
https://cvs.khronos.org/svn/repos/ogl/trunk/doc/registry/public/api/

We don't plan to maintain the old .spec files going forward and it
will not be fixed there; we'd like people to migrate to using the
XML registry for whatever external purposes they might be using
.spec for today, because .spec files are just too painful for us
to keep maintaining.