Khronos Public Bugzilla
Bug 20 - Lambert element definition incorrect
Lambert element definition incorrect
Status: RESOLVED DUPLICATE of bug 52
Product: COLLADA
Classification: Unclassified
Component: Specification
1.4.1
All All
: P3 normal
: Spec 1.4.1 2nd Ed.
Assigned To: Daniel Horowitz
: collada-fx
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-20 13:01 PDT by Frank Weed II
Modified: 2007-11-28 18:55 PST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Weed II 2006-09-20 13:01:08 PDT
<lambert> is currently defined as "The reflected color is calculated simply as: color = emission".  This appears to be a copy & paste error from <constant>.  The Introduction section should also be changed.
Comment 1 Mark Barnes 2006-09-22 18:31:15 PDT
Daniel please supply corrected text.
Comment 2 Daniel Horowitz 2007-03-29 02:33:02 PDT
color = <emissive> + 
<ambient>* Σ(AmbientLights, LightColor) + 
<diffuse>* Σ(OtherLights, LightColor*max(NdotL, 0))

where OtherLights includes all other light types (point, direction, spot)




Comment 3 Mark Barnes 2007-08-28 13:10:14 PDT
Daniel the descriptive text is also incorrect. Can you provide paragraphs for Introduction, Concepts, and Remarks?

Comment 4 Ellen Finch 2007-11-28 18:55:27 PST
ame as internal issue 792. https://cvs.khronos.org/bugzilla/show_bug.cgi?id=792

*** This bug has been marked as a duplicate of bug 52 ***