[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Public WebGL] Linux 64bit/minefield 3.7a6pre



Vladimir just checked it in:

http://hg.mozilla.org/mozilla-central/rev/3b3e795a1c2e


----- "Alan Chaney" <alan@mechnicality.com> wrote:

> Thanks, Benoit
> 
> Regards
> 
> Alan
> 
> On 06/14/2010 01:26 PM, Benoit Jacob wrote:
> > Hi,
> >
> > On X-based systems, in Minefield, WebGL depends (for its ability to
> use OpenGL) on this bug being fixed:
> >
> > https://bugzilla.mozilla.org/show_bug.cgi?id=565833
> >
> > I am already successfully using these patches (note it depends on
> 569775) with my nvidia card. Hopefully these changes will be checked
> in soon. Otherwise, you can always use software rendering with OSMesa,
> see
> > http://www.khronos.org/webgl/wiki/Getting_a_WebGL_Implementation
> >
> > Benoit
> >
> > ----- "Alan Chaney"<alan@mechnicality.com>  wrote:
> >
> >    
> >> Hi
> >>
> >> I have a Linux 64 bit Ubuntu 10.04 system with a ATI 5770 graphics
> >> card
> >> and the "propriertary" FGLX driver installed.
> >>
> >> glxinfo reports:
> >>
> >> direct rendering: Yes
> >> server glx vendor string: ATI
> >> server glx version string: 1.4
> >> server glx extensions:
> >>       GLX_ARB_multisample, GLX_EXT_import_context,
> >> GLX_EXT_texture_from_pixmap,
> >>       GLX_EXT_visual_info, GLX_EXT_visual_rating,
> GLX_OML_swap_method,
> >>       GLX_SGI_make_current_read, GLX_SGI_swap_control,
> >> GLX_SGIS_multisample,
> >>       GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
> >> GLX_SGIX_visual_select_group
> >> client glx vendor string: ATI
> >> client glx version string: 1.4
> >> client glx extensions:
> >> .......
> >>
> >> OpenGL vendor string: ATI Technologies Inc.
> >> OpenGL renderer string: ATI Radeon HD 5700 Series
> >> OpenGL version string: 3.2.9756 Compatibility Profile Context
> >> OpenGL shading language version string: 1.50
> >> OpenGL extensions:
> >>      .....
> >>
> >>
> >> Chromium 6.0.427.0 dev runs WebGL fine (using --enable-webgl in
> the
> >> invocation.)
> >> With Minefield 3.7a6pre and  about:config --->
> >> webgl.enabled_for_all_sites;true I get:
> >>
> >> Canvas 3D: creating PBuffer...
> >> Canvas 3D: can't get a native PBuffer, trying OSMesa...
> >> Canvas 3D: can't create a OSMesa pseudo-PBuffer.
> >>
> >> Does anyone have any suggestions?
> >>
> >> TIA
> >>
> >> Alan
> >>
> >>
> >>
> >>
> >>
> >>
> >>
> >>
> >>
> >>
> >> -----------------------------------------------------------
> >> You are currently subscribed to public_webgl@khronos.org.
> >> To unsubscribe, send an email to majordomo@khronos.org with
> >> the following command in the body of your email:
> >>      
> >
> > !DSPAM:4c1691e013541361014391!
> >
> >    
> 
> -----------------------------------------------------------
> You are currently subscribed to public_webgl@khronos.org.
> To unsubscribe, send an email to majordomo@khronos.org with
> the following command in the body of your email:
-----------------------------------------------------------
You are currently subscribed to public_webgl@khronos.org.
To unsubscribe, send an email to majordomo@khronos.org with
the following command in the body of your email: