Results 1 to 3 of 3

Thread: OpenCL 2.0 Compatibility with older GPU

  1. #1
    Newbie
    Join Date
    Jun 2014
    Posts
    1

    OpenCL 2.0 Compatibility with older GPU

    Hi every body,

    I will buy HD6670 GPU to develop OpenCL applications on Ubuntu 64bit with AthlonII X3 450.
    For exemple with Nvidia older GPU can run older CUDA driver.
    My question is Can I use OpenCL 2.0 with HD6670 and AthlonII X3 on Ubuntu 64bits ?

    Best regards

  2. #2
    Senior Member
    Join Date
    Dec 2011
    Posts
    168
    Not yet because AMD has not shipped an OpenCL 2.0 driver. When (or if) they do, it is up to AMD as to whether it will support the Radeon HD 6670 or only newer hardware.

  3. #3
    It is very unlikely that HD6670 will be able to support OpenCL 2.0. The HD6670 is based on Northern Island architecture, and as such missing a lot of the HW capabilities to support the minimal requirements set by OpenCL 2.0 - for example, device side enqueue.

    There is tight coupling between OpenCL 2.0 and HSA - and as such, AMD will probably use HSA as the lower layer to run OpenCL 2.0 on top of it. Which leads to a simple separation - if the card supports HSA (Kaveri, Hawaii), it will support OpenCL 2.0. Otherwise, it will support OpenCL 1.2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •