Results 1 to 2 of 2

Thread: OpenCL gDebugger

  1. #1
    Newbie
    Join Date
    Oct 2013
    Posts
    1

    OpenCL gDebugger

    Hi everyone,
    I am new to the forum, and I would like to search for help about gDebugger for openCL, eventually the version integrated in visual studio 2008.

    I installed gDebugger and tried to debug the project. I was not able to see and debug the source code since it displays that "the program is not running in no context mode" or something similar, and the icon of C++ is shaded. I am not able to import or visualize the source code in the gdebugger project once created.

    In the posts about OpenCL debugger here in the forum, I read that the CodeXL replaced gDebugger. I hope this is not completely true, since I recently tried to install the Catalyst drivers required to run CodeXL, but unfortunately they were skipped or aborted during the installation process, and as a conclusion the graphic drivers were reinstalled, causing OpenCL programs not to run anymore in visual studio. I am trying to restore the previous settings and run the programs again, but it's getting frustrating.

    I need to fix the problem, I ask u any kind of suggestion. I need a working debugger for the code, or at least a tool as a kernel analyzer to compare the performance between CPU/GPU.

    If it should be useful, I am working on a windows7 - 64bit platform, an ATI Radeon GPU device, visual studio 2008 and openCL 1.1.

    Thank you in advance.

    Marco

  2. #2
    Senior Member
    Join Date
    Oct 2012
    Posts
    166
    It's been a long time since i tried (and failed) to debug my OpenCL code that way. But didn't they say you need to have 2 GPU's to debug?
    I've tried it for 2 weeks to get gDebugger running and stopped after lots of disappointments

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •