Results 1 to 4 of 4

Thread: Image editing problem

  1. #1
    Junior Member
    Join Date
    Sep 2012
    Posts
    8

    Image editing problem

    Hello Khronos Community,

    I've tried to run the code given in http://www.khronos.org/message_board...hp?f=37&t=2495 with the given input picture but i only get a totally black 512x512 output.bmp.
    I've been struggling with this for a while now but i can't figure out whats going wrong. Any ideas?

    By the way clCreateImage2d is deprecated in OpenCL 1.2 specs. So should i use it under OpenCL 1.1 / 1.0 ? Are there any alternatives or should images be processed as arrays?

    I'd also appreciate any help (hints, sample code) relating image transfer from host to kernel and back.

    Thanks jabak.

  2. #2
    Junior Member
    Join Date
    Sep 2012
    Posts
    8

    Re: Image editing problem

    Can no one imagine a problem?

  3. #3
    Senior Member
    Join Date
    Aug 2011
    Posts
    271

    Re: Image editing problem

    Quote Originally Posted by jabak
    Can no one imagine a problem?
    I can imagine more problems than I care to ... although i don't think that's what you were asking.

    clCreateImage2d is just replaced with a more generic clCreateImage in opencl 1.2, but the old one is required for <1.2.

    Rather than start with random samples from forums, try looking at the samples provided with the vendor SDK.

  4. #4
    Junior Member
    Join Date
    Sep 2012
    Posts
    8

    Re: Image editing problem

    clCreateImage2d is just replaced with a more generic clCreateImage in opencl 1.2, but the old one is required for <1.2.
    I already found that out. At the beginning i thought it was completely abondoned.
    But thanks.

    Rather than start with random samples from forums, try looking at the samples provided with the vendor SDK.
    My vendor isnt providing an SDK and anyway, most of the samples from the SDKs are quite large and with to much overhead to get quick results so I tried to use this small one to extract the basics.

Similar Threads

  1. Striped Image problem
    By wrx in forum OpenCL
    Replies: 13
    Last Post: 03-02-2011, 12:18 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •