Results 1 to 5 of 5

Thread: OSX 10.8, GeForce GT 650M, Can't create command queues

  1. #1
    Junior Member
    Join Date
    Aug 2012
    Posts
    2

    OSX 10.8, GeForce GT 650M, Can't create command queues

    Support for the GT 650M seems to be broken. My JOCL based test application test fails with CL_INVALID_VALUE when creating, as does Apples own Hello World

    Does anybody have similar issues?

    OS X 10.8.1
    GeForce GT 650M in Retina MacBook Pro

  2. #2
    Junior Member
    Join Date
    Aug 2012
    Posts
    2

    Re: OSX 10.8, GeForce GT 650M, Can't create command queues

    Since the discovery of the problem, I found out that it somehow was connected with the machine going to sleep, because it seemed that after waking up from sleep the problems occurred, but not after a fresh reboot.

    I moved my OpenCL endeavors to a another, Linux based, machine since then.

    I'm now on 10.8.2, XCode 4.5 (updated from 10.8.1, fresh install of Xcode from developer.apple.com not via AppStore) and just ran some tests with succes, even when waking up from sleep. I couldn't reproduce now.

    Unfortunately I don't know what exactly helped the problem for the time being. My OSX environment is complicating the issue, as I have one admin account to install applications, and a development account that only has default user permissions. Because of this I ran into compilation problems with other non-OpenCL projects (forcing me to run `sudo xcodebuild -license` on development account, after `su admin`, without sudo I had some problems). What I see when I first started XCode 4.5 (fresh install!) from the development account was a dialog asking for admin permissions to install "Device Components" (whatever that is). So maybe some of that helped.

  3. #3
    Junior Member
    Join Date
    Oct 2009
    Posts
    4

    Re: OSX 10.8, GeForce GT 650M, Can't create command queues

    I observe a similar issue, which I reported to Apple a while ago (radar #1218677. Maybe this is related to your problem:

    Simply creating a context and a command queue, and then building a kernel and finally releasing everything again works on a new MacBook Pro Retina w/ Nvidia 650m only ~25 times. After that I get an OpenCL error -30 and I have to reboot the machine in order to be able to create a command queue again (in any OpenCL app). This can be reproduced on several rMBPs on 10.8.x, but not on other Macs.

    I have a simple test tool, if you are interested.

    cheers,
    --Philippe

  4. #4
    Junior Member
    Join Date
    Oct 2009
    Posts
    4

    Re: OSX 10.8, GeForce GT 650M, Can't create command queues

    FYI Apple confirmed they could reproduce the problem. NVIDIA so far did not yet deliver a fix, though.

    cheers
    --Philippe

  5. #5
    Junior Member
    Join Date
    Feb 2010
    Posts
    5

    Re: OSX 10.8, GeForce GT 650M, Can't create command queues

    Resurrecting this thread, please post back here if you guys find a solution to the problem. This is affecting a product that I am building for the Mac App Store

Similar Threads

  1. Devices and command queues
    By absence in forum OpenCL
    Replies: 4
    Last Post: 01-17-2010, 11:24 PM
  2. Replies: 3
    Last Post: 12-08-2009, 10:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •