Hello, I am working with the Qualcomm AR SDK and I have used a Perl script to transform a banana model (.obj) to my own layout of arrays. All works correctly apart from the model texturing repeats on every face instead of stretching over the entire model. Blender shows the model correctly before I scale it while rendering in the application.

Does anybody have any idea of what to do or what to check to fix this? I have been struggling for a few days now!

Others have done this same thing with the same model and script without problems.



Code :
// Constants:
static const float kObjectScale = 90.0f;
 
const Texture* const thisTexture = textures[0];
 
        glUseProgram(shaderProgramID);
 
        glVertexAttribPointer(vertexHandle, 3, GL_FLOAT, GL_FALSE, 0,
                              (const GLvoid*) &vertArray[0]);
        glVertexAttribPointer(normalHandle, 3, GL_FLOAT, GL_FALSE, 0,
                              (const GLvoid*) &normalsArray[0]);
        glVertexAttribPointer(textureCoordHandle, 2, GL_FLOAT, GL_FALSE, 0,
                              (const GLvoid*) &coordsArray[0]);
 
 
        glEnableVertexAttribArray(vertexHandle);
        glEnableVertexAttribArray(normalHandle);
        glEnableVertexAttribArray(textureCoordHandle);
 
 
        glActiveTexture(GL_TEXTURE0);
        glBindTexture(GL_TEXTURE_2D, thisTexture->mTextureID);
        glUniformMatrix4fv(mvpMatrixHandle, 1, GL_FALSE,
                           (GLfloat*)&modelViewProjection.data[0] );
        glDrawArrays(GL_TRIANGLES, 0, VERTEX);

I think that is all the code which will help,

Any information is welcomed!