Hello,

Its pretty anoying have prepared an application that works well with a certail OpenCL version, and when the new driver comes, with support for the next OpenCL version, some things of the application stops to work as expected. For instance, new versions introduces new error codes, and if I have controlled the ones that comes with a version, new error codes really annoy me.

I'm talking in terms of application stability. If I prepare an application to use one CL version, it ALWAYS MUST use that version, like OpenGL does when I specify the context I want to instance.

I wonder why OpenCL didn't follow OpenGL steps in this matter. Driver complexity perhaps?