Results 1 to 3 of 3

Thread: Webgl Texture

  1. #1
    Junior Member
    Join Date
    Mar 2012
    Posts
    2

    Webgl Texture

    Hi,
    I am learning webgl now. When i tried to use texture, nothing was working for me.
    I just copied the code from the following link to my machine and tried, but the texture was not working.

    https://cvs.khronos.org/svn/repos/regis ... itBox.html

    I also copied the code from some other website and tried. At that time also it was not working for me. I checked the image size all the time. It was power of 2.(like 256x256.. 512x512...)

    Could you please tell me what is going wrong here?

    Thanks in advance,
    Dheepan.

  2. #2
    Junior Member
    Join Date
    Mar 2012
    Posts
    3

    Re: Webgl Texture

    can you run your code on some server or your localhost?
    it is possible, that your proble doesnt allow you to use the texture file
    when the code is run locally

  3. #3
    Junior Member
    Join Date
    Mar 2012
    Posts
    2

    Re: Webgl Texture

    Hi matej,
    Thanks for your reply. The problem is exactly what you have specified. Google chrome is not allowing the local files to run.. To make it work, we have to run the chrome browser with the following flag.
    "--allow-file-access-from-files".
    Now its working well. Thanks for your time and effort.

Similar Threads

  1. WebGl Extension ImagKHR for fast video texture mapping
    By WilliamGL in forum WebGL - General
    Replies: 0
    Last Post: 03-20-2012, 04:15 AM
  2. Render texture to other webgl canvas element
    By klapsd in forum Developers Coding:Beginner
    Replies: 3
    Last Post: 02-13-2012, 02:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •