Results 1 to 3 of 3

Thread: clBuildProgram crashes in Intel platform

  1. #1

    clBuildProgram crashes in Intel platform

    Hello,

    I have an application that runs fine in GPU, but when I chose the Intel CPU as platform, clBuildProgram crashes. clCreateProgramWithSource returns what appears to be a valid cl_program and the last parameter (the error) is filled with 0 (success)

    Do you have any experience with an issue like this?

    Thank you.

  2. #2

    Re: clBuildProgram crashes in Intel platform

    Only as clarification: the crash that happens is:
    Unhandled exception at 0x00000000 in PublicLayer_Debug.MetriaApps.PublicLayerSample.exe : 0xC0000005: Access violation.
    in this line:

    error = clBuildProgram(program, 0, NULL, NULL, NULL, NULL);

    As said, program seems to be valid, because clCreateProgramWithSource executes ok, and clGetProgramInfo returns valid info about the program.

  3. #3

    Re: clBuildProgram crashes in Intel platform - SOLVED

    Ok, problem solved. Internally, the Intel's OpenCL driver uses TBB, and in our project we was using TBB too, but an older version. Our TBB dll's was being copied to our bin folder, so when the Intel's driver tried lo load their TBB, it was loading an obsolete version, so that's why it was crashing.

    I hope this post serves to somebody if they experience the same issues.

Similar Threads

  1. clBuildProgram crashes
    By AlexAtOSU in forum OpenCL
    Replies: 2
    Last Post: 08-11-2010, 09:22 AM
  2. clBuildProgram crashes with varying kernel args
    By poonaatsoc in forum OpenCL
    Replies: 2
    Last Post: 12-24-2009, 05:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •