Results 1 to 2 of 2

Thread: Replace get_num_groups with get_group_size

  1. #1
    Senior Member
    Join Date
    Mar 2011
    Location
    Seoul
    Posts
    118

    Replace get_num_groups with get_group_size

    Sorry to be a little picky, but I noticed a few places in OpenCL that are inconsistent with a naming convention. Case in point is get_global_id, get_local_id, and get_group_id. Instead of having get_global_size, get_local_size, and get_num_groups, how about follow one or the other to make them all the same, like deprecate get_num_groups and provide get_group_size instead.

  2. #2

    Re: Replace get_num_groups with get_group_size

    I noticed this as well, it's just a minor flaw but still quite annoying at times.

Similar Threads

  1. Will OpenCL replace OpenGL in the future?
    By joek02 in forum OpenCL
    Replies: 1
    Last Post: 04-18-2010, 09:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •