Results 1 to 10 of 10

Thread: Getting WebGL in Chrome at the moment

  1. #1
    Junior Member
    Join Date
    Jan 2011
    Posts
    3

    Getting WebGL in Chrome at the moment

    WebGL is disabled by default in the latest Chrome Beta (9.0.597.45). To get WebGL in Chrome, you need to either:

    1) Run the Chrome Beta with the ''--enable-webgl' flag from the command line:

    chrome.exe --enable-webgl

    Chrome Beta can be downloaded here: http://www.google.com/landing/chrome/beta/

    2) Run the Chromium nightly build

    Instructions for getting Chromium here: http://khronos.org/webgl/wiki/Getting_a ... 2FChromium (Make sure to get the Chromium nightly build, not the Chrome Beta.)


    Just running the Chrome Beta is not enough for the time being.

    Hopefully this will get fixed soon.

    David

  2. #2
    Junior Member
    Join Date
    Jan 2011
    Posts
    3

    Re: Getting WebGL in Chrome at the moment

    Correction: For #2, it's called the Chromium continuous build, not the nightly build.

  3. #3
    Junior Member
    Join Date
    Jan 2011
    Posts
    3

    Re: Getting WebGL in Chrome at the moment

    Also, for #1, if you see performance problems, it may help to add the flag --enable-accelerated-compositing:

    chrome.exe --enable-webgl --enable-accelerated-compositing

  4. #4

    Re: Getting WebGL in Chrome at the moment

    Hello.

    I am new around here. I tried unsuccesfully the way 1 on an ubuntu 10.04 machine with Google Chrome 9.0.597.45 beta.
    There the chrome.exe does not exist, but there is a file called google-chrome, when I launch
    Code :
    ./google-chrome --enable-webgl
    the browser starts ok but when I try to go to bodybrowser.googlelabs.com it doesn't work and tells me I need a Web browser that supports WebGL.



    I see this in the terminal where I launched the command:
    Code :
    madrid@max60:/opt/google/chrome$ ./google-chrome --enable-webgl 
    [3644:3644:876802284:ERROR:base/native_library_linux.cc(32)] dlopen failed when trying to open libGLESv2.so: libGLESv2.so: no se puede abrír el archivo de objeto compartido: No existe el archivo o directorio
    [3644:3644:876807776:ERROR:app/gfx/gl/gl_context_linux.cc(539)] glXChooseFBConfig failed.
    [3644:3644:876821471:ERROR:gpu/command_buffer/service/context_group.cc(73)] ContextGroup::Initialize failed because too few texture units supported.
    [3644:3644:876821498:ERROR:gpu/command_buffer/service/gles2_cmd_decoder.cc(1806)] GPUProcessor::InitializeCommon failed because group failed to initialize.
    [3644:3644:876822251:ERROR:gpu/command_buffer/service/gpu_processor.cc(78)] GPUProcessor::InitializeCommon failed because decoder failed to initialize.
    [3644:3644:876822959:ERROR:app/gfx/gl/gl_context_linux.cc(539)] glXChooseFBConfig failed.
    [3644:3644:876825871:ERROR:gpu/command_buffer/service/context_group.cc(73)] ContextGroup::Initialize failed because too few texture units supported.
    [3644:3644:876825896:ERROR:gpu/command_buffer/service/gles2_cmd_decoder.cc(1806)] GPUProcessor::InitializeCommon failed because group failed to initialize.
    [3644:3644:876826599:ERROR:gpu/command_buffer/service/gpu_processor.cc(78)] GPUProcessor::InitializeCommon failed because decoder failed to initialize.

    Any idea? Thanks in advance.

  5. #5
    Junior Member
    Join Date
    Jan 2011
    Posts
    1

    Re: Getting WebGL in Chrome at the moment

    The link http://www.google.com/landing/chrome/beta/ cannot be reached with either Google Chrome 8.0.552.224 beta or Internet Explorer 8.0.7600.16385.

    Firefox is able to reach the page

  6. #6
    Senior Member
    Join Date
    May 2010
    Posts
    207

    Re: Getting WebGL in Chrome at the moment

    It sounds like the reason you can't get Chrome to support WebGL may be to do with your underlying OpenGL implementation. What graphics card do you have? Can you run other OpenGL applications OK?

  7. #7
    Junior Member
    Join Date
    Jan 2011
    Posts
    1

    Re: Getting WebGL in Chrome at the moment

    I would like to try Google body on my intel mac os 10.6
    I downloaded Google Chrome beta and navigated to /Applications/Google Chrome/Contents/MacOS

    there is no executable file named chrome
    the executable is named Google Chrome
    If I change the name of the file to Google-Chrome it does not launch Chrome
    When I type ./Google Chrome --enable-webgl in the terminal window the space character in Google Chrome terminates the string so
    I tried ./."Google Chrome" --enable-webgl
    ./"Google Chrome --enable-webgl"
    and ./Google%20Chrome --enable-webgl
    none of these work

  8. #8
    Junior Member
    Join Date
    Jan 2011
    Posts
    5

    Re: Getting WebGL in Chrome at the moment

    The easiest way to get it working is by installing Chrome from dev channel. Just keep in mind that these are development builds and sometimes they can have some strange bugs. Check this page: https://sites.google.com/a/chromium.org ... ev-channel for install instructions

  9. #9
    Senior Member
    Join Date
    May 2010
    Posts
    207

    Re: Getting WebGL in Chrome at the moment

    I've been seeing lots of problems with both Chrome and Safari on the Mac. Since they are both based on the same "WebKit" display routines, they tend to share the same kinds of bugs.

    If you have problems with Chrome, I recommend downloading a copy of Firefox 4 (beta) and trying with that.

    WebGL is still a "work in progress" and significant bugs still pop up from time to time.

    For example, over the last few days, both Chrome and Safari have been killing off shaders that have any single or double quote characters in their comments(!) - since companies like Google tend to stamp gigantic copyright/legal notices on their shaders, often containing things like:

    // This software is provided on an "as is" basis...

    ...which is exactly the kind of thing that Safari and Chrome were having trouble with. That bug got fixed today...but maybe you don't have the fix yet.

    So right now, if something fails in one browser, it's worth trying a different one.

    However, these pieces of software are getting stronger and stronger every day - bugs like this are becoming more and more rare.

    -- Steve

  10. #10

    Re: Getting WebGL in Chrome at the moment

    Thanks for the answers and excuse my delay in answering.

    I still haven't been able to have bodybrowser working in linux (ubuntu 10.04 64bit) in my PC (it works ok in my windows XP partition with chromium but it fails in my windows 7 virtual machine in the ubuntu host).

    My video card is "RV410 [Radeon X700 (PCIE)]".

    I have never tried other webgl applications.

    I downloaded the latest chrominium release, but when I try the Body Browser I get this:
    Code :
    [4398:4398:7178434377:ERROR:gl_context_linux.cc(558)] glXChooseFBConfig failed.
    [4398:4398:7178455655:ERROR:context_group.cc(73)] ContextGroup::Initialize failed because too few texture units supported.
    [4398:4398:7178455683:ERROR:gles2_cmd_decoder.cc(1807)] GPUProcessor::InitializeCommon failed because group failed to initialize.
    [4398:4398:7178456391:ERROR:gpu_processor.cc(78)] GPUProcessor::InitializeCommon failed because decoder failed to initialize.
    [4398:4398:7178456951:ERROR:gl_context_linux.cc(558)] glXChooseFBConfig failed.
    [4398:4398:7178460064:ERROR:context_group.cc(73)] ContextGroup::Initialize failed because too few texture units supported.
    [4398:4398:7178460087:ERROR:gles2_cmd_decoder.cc(1807)] GPUProcessor::InitializeCommon failed because group failed to initialize.
    [4398:4398:7178460791:ERROR:gpu_processor.cc(78)] GPUProcessor::InitializeCommon failed because decoder failed to initialize.
    [4398:4398:7178465314:ERROR:context_group.cc(73)] ContextGroup::Initialize failed because too few texture units supported.
    [4398:4398:7178465338:ERROR:gles2_cmd_decoder.cc(1807)] GPUProcessor::InitializeCommon failed because group failed to initialize.
    [4398:4398:7178469156:ERROR:gpu_processor.cc(78)] GPUProcessor::InitializeCommon failed because decoder failed to initialize.
    [4398:4398:7178469702:ERROR:gl_context_linux.cc(558)] glXChooseFBConfig failed.
    [4398:4398:7178472997:ERROR:context_group.cc(73)] ContextGroup::Initialize failed because too few texture units supported.
    [4398:4398:7178473020:ERROR:gles2_cmd_decoder.cc(1807)] GPUProcessor::InitializeCommon failed because group failed to initialize.
    [4398:4398:7178474196:ERROR:gpu_processor.cc(78)] GPUProcessor::InitializeCommon failed because decoder failed to initialize.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •