Results 1 to 2 of 2

Thread: cube map textures.

  1. #1
    Junior Member
    Join Date
    Oct 2010
    Posts
    7

    cube map textures.

    I am having some issues with cube map textures. Could you please help me in solving this out.

    1) when I call glCopyTexSubImage2D(GL_TEXTURE_CUBE_MAP_POSITIVE_X + i ,0,0,0,0,0,128,12, I am expecting half of each surface of cube texture replaces with the subtexture(from the framebuffer). where my originol texture array is 256x256 of size. If I call file_glCopyTexSubImage2D(GL_TEXTURE_CUBE_MAP_POSIT IVE_X + i ,0,0,0,0,0,256,256), the whole cube is replaced with the subtexture. I am not able to see old texture. which is correct behaviour I think.

    Could you please tell me why it is like this? I am not ablr to change half of the cube map texture.

    2) When I call glCompressedTexImage2D() or glcompressedtexsubimage2d for cubemap. I am expecting whole complete compressed Image data on each surface of cube. but It just using half of or part of compressed texture for rendering whole surface of cube.
    I mean my compressed image is having scene with sky and trees, than on cube I am just getting sky only.... no trees.

    Thanking you.

  2. #2
    Junior Member
    Join Date
    Oct 2010
    Posts
    7

    Re: cube map textures.

    I've used wrong quadrants. Problem solved.

Similar Threads

  1. glTexSubImage2D and cube map texture
    By HappyZappy in forum OpenGL ES general technical discussions
    Replies: 1
    Last Post: 11-09-2010, 08:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •