Friend told me Firefox WebGL had improved, so I retried and get this for everything WebGL (e.g. particles demo):
Code :
This demo requires a WebGL-enabled browser.
 
In Error log console:
Canvas 3D: creating PBuffer...
Canvas 3D: can't get a native PBuffer, trying OSMesa...
Canvas 3D: can't create a OSMesa pseudo-PBuffer.
However, retrying firefox-3.7a2, most WebGL demos come up. However, firefox-3.7a5 is broke too (same as 3.7a6).

Am I doing something wrong? Or are recent Firefox WebGL's just broken?