Results 1 to 4 of 4

Thread: compilation error in VS2008,HELP!

  1. #1
    Junior Member
    Join Date
    May 2010
    Posts
    5

    compilation error in VS2008,HELP!

    I downloaded a demo of OPENCL named HelloCL and it runs well in VS2008.But once I create a new project and copy the code of HelloCL into it,change the relevant options in new project properties as well, there are too many compilation error. By the way,I use ATIStreamSDK.
    The changes in new project properties as follow:
    1."Configuration Properties"->"C/C++"->"Addtional Include Directories".
    2."Configuration Properties"->"Linker"->"General"->"Addtional Include Directories".
    3."Configuration Properties"->"Linker"->"Input"->"Addtional Dependencies".
    Does anybody tell me what mistake did I take or did I omit anything?

  2. #2
    Junior Member
    Join Date
    May 2010
    Posts
    5

    Re: compilation error in VS2008,HELP!

    otherwise?the compilatin errors are almost like the kind "XX is Undeclared identifier",XX is OPENCL data type like "cl_int".

  3. #3
    Senior Member
    Join Date
    May 2010
    Location
    Toronto, Canada
    Posts
    845

    Re: compilation error in VS2008,HELP!

    It sounds like you did not include cl.h correctly. Check again your "additional include directories" and make sure that your application has the following statement at the top of your source code:
    Code :
    #include <CL/cl.h>

    Since you have HelloCL working correctly on your PC I suggest looking again at all the options that have been set in that project and make sure that all the settings in your project look the same.
    Disclaimer: Employee of Qualcomm Canada. Any opinions expressed here are personal and do not necessarily reflect the views of my employer. LinkedIn profile.

  4. #4
    Junior Member
    Join Date
    May 2010
    Posts
    5

    Thanks for reply

    I solved it ,thank you!

Similar Threads

  1. Hello world program - compilation error
    By chomolungma in forum OpenCL
    Replies: 5
    Last Post: 02-22-2010, 05:01 PM
  2. fatal error C1189: #error : ERROR: Use of C runtime library
    By gjermani in forum OpenGL ES general technical discussions
    Replies: 1
    Last Post: 09-24-2007, 03:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •