Results 1 to 2 of 2

Thread: Not correct transparent textures in GL_POINT_SPRITE_OES

  1. #1
    Junior Member
    Join Date
    Mar 2010
    Posts
    1

    Not correct transparent textures in GL_POINT_SPRITE_OES

    Need help to display a particle in 3D!
    Correctly handle transparent textures of particles in GL_POINT_SPRITE_OES only when enable GL_DEPTH_TEST and glDepthFunc (GL_ALWAYS) or when the disable GL_DEPTH_TEST, in other cases, the transparency does not work well, but I am interested to work properly transparent particles enable GL_DEPTH_TEST and glDepthFunc(GL_LESS). tried different options glBlendFunc not help. 'll Show how to do? or where to see the source? I studied library OOLONG for the iPhone but there is an example where enable GL_DEPTH_TEST and glDepthFunc(GL_ALWAYS).

  2. #2
    Senior Member
    Join Date
    May 2006
    Posts
    353

    Re: Not correct transparent textures in GL_POINT_SPRITE_OES

    If you need particles to properly occlude each other (for many types of particles that's not necessary, by the way), then you need to sort them back-to-front. OpenGL ES does not provide an automatic way to do this.
    Georg Kolling, Imagination Technologies
    Please ask questions specific to PowerVR hardware or SDKs on the PowerVR Insider Forum
    DevTech@imgtec.com | http://www.powervrinsider.com

Similar Threads

  1. What is the correct way to create buffer?
    By EdwardComb in forum OpenGL ES 1.X - fixed function hardware
    Replies: 0
    Last Post: 05-11-2011, 10:02 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •