Results 1 to 4 of 4

Thread: Compile messaged from NVidia OpenCl compiler on Windows

  1. #1
    Junior Member
    Join Date
    Mar 2010
    Location
    Germany
    Posts
    21

    Compile messaged from NVidia OpenCl compiler on Windows

    Hi there,

    I get some compile messages from the NVidia compiler. The compile doesn't fail, I just wonder, what these messages are for :

    : Retrieving binary for 'anonymous_jit_identity', for gpu='sm_11', usage mode=''
    : Considering profile 'compute_10' for gpu='sm_11' in 'anonymous_jit_identity'
    : Control flags for 'anonymous_jit_identity' disable search path
    : Ptx binary found for 'anonymous_jit_identity', architecture='compute_10'
    : Ptx compilation for 'anonymous_jit_identity', for gpu='sm_11', ocg options=''

    These happen on a 9800 GX2 and 9600 GT. Not on CPU or ATI compiling.

    Thanks for help.

  2. #2
    Junior Member
    Join Date
    Mar 2010
    Posts
    2

    Re: Compile messaged from NVidia OpenCl compiler on Windows

    Hello!

    I have a similar problem. I get the error:

    : Retrieving binary for 'anonymous_jit_identity', for gpu='sm_11', usage mode=''

    while running my code on an NVIDIA Quadro GPU. To be more precise the error apparently occurs when I want to retrieve the results from the GPU to the host, i.e. the Build Log gives me the response above and my debug message "Error: clEnqueueReadBuffer (Reading back the result *FAILED*)" is printed out. The relevant code being:

    Code :
    err = clEnqueueReadBuffer(queue, img_mem, CL_TRUE, 0, image_buffer_size, _result.data(), 0, NULL, NULL);
    if(err != CL_SUCCESS) 
    	cout<<"Error: clEnqueueReadBuffer (Reading back the result *FAILED*) \n\n";
     
    // Synchronize: Force the queue to complete the task. (Blocking command)
    clFinish(queue);

    The program works on my laptop but the kernel is emulated since my ATI graphics card is too old. But still, the computation is performed correctly there, but does not work with NVIDIA.

    Note: I'm using Windows 7, Visual Studio 2008 and the NVIDIA Toolkit 2.3.
    I'm not an advanced programmer, so please excuse me if the mistake is trivial. I'm learning as fast as I can

    I would be grateful for any advice and help. Thank you!

  3. #3
    Junior Member
    Join Date
    Mar 2010
    Location
    Germany
    Posts
    21

    Re: Compile messaged from NVidia OpenCl compiler on Windows

    The returning status value does give you more information than just *Failed*. Try to give it to the log (cout), so you could have a look into the cl.h to see, what this error means. I get a -5, what means not enough resources are available.
    The compile messages are no error (else you could not init the kernel) just messages or warnings. Just wanna know, what they are for.

  4. #4
    Junior Member
    Join Date
    Mar 2010
    Posts
    2

    Re: Compile messaged from NVidia OpenCl compiler on Windows

    Ah, right. I found the error codes.
    Will definitely try it out next time I get the chance (unfortunately have to wait till the middle of next week now).
    Thanks for the help!

Similar Threads

  1. Replies: 1
    Last Post: 01-26-2012, 12:14 AM
  2. Replies: 2
    Last Post: 04-19-2011, 11:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •