Results 1 to 2 of 2

Thread: Firefox: Need to set webgl.osmesalib for hwaccel on win7/64

  1. #1

    Firefox: Need to set webgl.osmesalib for hwaccel on win7/64

    I'm not even sure this is a bug or intentional behavior, but I haven't found any documentation on it, so I think it's probably a good idea to document this somewhere, and the official forum doesn't seem like a bad place.

    I also haven't filed a bug on it yet, since I'm not even sure it is a bug so far.

    I'm using Windows 7/64 and current trunk builds (at least up to 20100205) are unable to do hardware accelerated WebGL by just setting webgl.enabled_for_all_sites. Instead, you have to provide the path to the system OpenGL library via webgl.osmesalib. This could be because the opengl32.dll doesn't reside in the system32 directory on 64bit editions of Windows ... or something else, I don't know. Setting it to the SysWOW64 folder instead fixes the issue for me (i.e. C:\Windows\SysWOW64\opengl32.dll)

    Can anybody shed some light on this?

  2. #2
    Junior Member
    Join Date
    Dec 2010
    Location
    United States
    Posts
    1

    Re: Firefox: Need to set webgl.osmesalib for hwaccel on win7

    I think you can find some useful instructions to the problem of yours from http://khronos.org/webgl/wiki/Getting_a ... ementation
    Live your life with a style.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •