Results 1 to 6 of 6

Thread: Error: eglInitialize() failed.

  1. #1

    Error: eglInitialize() failed.

    Hi all,
    I'm trying to run OpenVG demos on TI OMAP3430 ,
    Compilation was successfull . I tried to run OpenVG initialization demo ,

    root@vx20000:/mnt# ./OVGInitialization
    Error: eglInitialize() failed.

    Please help me to resolve this.

    Best Regards
    chandra

  2. #2

    Re: Error: eglInitialize() failed.

    You'll definitely need to post more details if anyones going to have a chance at helping you. For starters:

    Which OS is your target running?
    What driver are you running?
    Which EGL/VG implementation are you using?

  3. #3

    Re: Error: eglInitialize() failed.

    Dear jpilon,
    I'm trying to run OpenVG initialization demo on
    1."Linux 2.6.24.7-omap1-arm2" running on omap3430.
    2.Version - How to get the version number?
    3.we are using pvrsrvkm module.

    Best regards
    chandra

  4. #4

    Re: Error: eglInitialize() failed.

    Dear All,

    Looks like platform was unstable.
    Now its initializing we are able to run the sample applications.

    Thanks jpilon.


    Best Regards
    chandra

  5. #5
    Junior Member
    Join Date
    Jun 2010
    Posts
    1

    Re: Error: eglInitialize() failed.

    Hi I have same problem on my HTC HD2.

    Code :
       EGLint iMajorVersion, iMinorVersion;
       eglDisplay = eglGetDisplay(hDC);
       if (eglInitialize(eglDisplay, &iMajorVersion, &iMinorVersion) == EGL_FALSE)

    eglDisplay is valid pointer but eglInitialize always returns EGL_FALSE. Do I need to pass some special attributes CreateWindow (so far I'm using default VS 2008 functions)?

    I've tried example test program from http://www.philippewechsler.ch/Download.php which runs just fine.

  6. #6

    Re: Error: eglInitialize() failed.

    The eglInitialize() function is very platform depended, make sure your running with all the correct libraries and your environment is setup correctly. You can try running your applications with DL_DEBUG=1, to see if there's any fishy.

Similar Threads

  1. Assertion failed Error for VG_TRUE in Open VG
    By sowmyaa in forum OpenVG and VGU
    Replies: 2
    Last Post: 05-02-2012, 12:16 AM
  2. Replies: 0
    Last Post: 03-28-2010, 07:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •