Results 1 to 3 of 3

Thread: Anyone used the Z430 in the Snapdraggon?

  1. #1
    Junior Member
    Join Date
    Jan 2010
    Posts
    4

    Anyone used the Z430 in the Snapdraggon?

    The Z430 is doing my nut in!! Code which works on other implementations just plain doesn't work.

    Anyone had any success with this device?

    Cheers
    Jim

  2. #2
    Junior Member
    Join Date
    Jan 2010
    Posts
    4

    Re: Anyone used the Z430 in the Snapdraggon?

    Just some more info

    I did some debugging and it looks like the

    eglMakeCurrent(egldisplay, eglsurface, eglsurface, eglcontext);

    is failing with a EGL_BAD_SURFACE

    looking at the attributes of the surface when it was created it has a 0 width and 0 height. Using GetClientRect(hWnd, &rect); prior to this shows the window had a valid width and height. The window didn't fail creation checked the error and I got EGL_SUCCESS from

    eglsurface = eglCreateWindowSurface(egldisplay, eglconfig, (NativeWindowType)hWnd, NULL);

    Any ideas why the width/height would be zero?

    Jim

  3. #3
    Junior Member
    Join Date
    Jan 2010
    Posts
    4

    Re: Anyone used the Z430 in the Snapdraggon?

    Got it working after some great pain.

    looks like the driver is just wrong

    width and height are 0

    eglMakeCurrent() always returns back EGL_BAD_SURFACE but if I ignore this and just continuing the rendering completes

    the worst problem is I have to set

    vgSeti(VG_MATRIX_MODE, VG_MATRIX_PATH_USER_TO_SURFACE)

    or I just get a black screen, even though this is supposed to be the default state for this parameter

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •