edit: figured out my problem..forgot #extension GL_EXT_gpu_shader4 : enable